games-fps/ut2004-bonuspack-ece: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sun, 20 Oct 2019 21:57:19 +0000 (23:57 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 27 Oct 2019 23:47:59 +0000 (23:47 +0000)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r4.ebuild [moved from games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild with 79% similarity]

similarity index 79%
rename from games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
rename to games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r4.ebuild
index e5ebe2ab3b90fc8ab10b13240d7c5eb92fa64216..5460ac93230ac50d38a5032c258a0919b822df6a 100644 (file)
@@ -1,29 +1,34 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-MOD_DESC="Editor's Choice Edition bonus pack"
-MOD_NAME="Editor's Choice Edition"
-
-inherit games games-mods
+EAPI=7
 
 MY_P="ut2004megapack-linux.tar.bz2"
+
+DESCRIPTION="UT2004 Editor's Choice Edition - Editor's Choice Edition bonus pack"
 HOMEPAGE="http://www.unrealtournament2004.com/"
-SRC_URI="http://ut2004.ut-files.com/BonusPacks/${MY_P}
+SRC_URI="
+       http://ut2004.ut-files.com/BonusPacks/${MY_P}
        http://unrealmassdestruction.com/downloads/ut2k4/essentials/UT2004-ONSBonusMapPack.zip"
 
 LICENSE="ut2003"
+SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
 
 src_unpack() {
-       unpack ${MY_P}
+       unpack "${MY_P}"
+
        cd UT2004MegaPack/Maps || die
        unpack UT2004-ONSBonusMapPack.zip # bug #278002
 }
 
 src_prepare() {
+       default
+
        mv -f UT2004MegaPack/* . || die
        rmdir UT2004MegaPack || die
 
@@ -54,3 +59,10 @@ src_prepare() {
        rm System/{Core.int,Engine.int,Setup.int,Window.int} || die
        rm System/{OnslaughtFull.u,OnslaughtBP.u} || die
 }
+
+src_install() {
+       insinto /opt/ut2004
+       doins -r Animations Help Maps Sounds StaticMeshes System Textures
+
+       dosym ut2004 /opt/ut2004-ded
+}