dev-python/matplotlib: replaced an incomplete 2.1.0 tarball by the full one
authorAndrey Grozin <grozin@gentoo.org>
Fri, 10 Nov 2017 11:14:15 +0000 (18:14 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Fri, 10 Nov 2017 11:14:15 +0000 (18:14 +0700)
The released source tarball of matplotlib-2.1.0 has many files missing.
I've checked out the v2.1.0 tar from their git and prepared a better tarball.
Closes: https://bugs.gentoo.org/636848
Package-Manager: Portage-2.3.13, Repoman-2.3.4

dev-python/matplotlib/Manifest
dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild [new file with mode: 0644]

index d3db25ffa58beafcd9ab82c41678b3fdd7207bb4..4a07535caec87b23fef2eb7096fa2aad7d353634 100644 (file)
@@ -1,4 +1,5 @@
 DIST matplotlib-1.4.3.tar.gz 49933525 SHA256 5b9544472d9d6ab3d47423bdb5a0e64fdf913e505c1c083f25283dd0362bc0b6 SHA512 51b0f58b2618b47b653e17e4f6b6a1215d3a3b0f1331ce3555cc7435e365d9c75693f289ce12fe3bf8f69fd57b663e545f0f1c2c94e81eaa661cac0689e125f5 WHIRLPOOL 160ca48ecb44db58f1c56bd6e89592c5d1badd8e434fc25d32aa6d4d7a346ae7c7444d1c8e0c2ca2bf5c3246fd56cd93856ec7b1e3e51f5e471b9b55a0f2c1ad
 DIST matplotlib-1.5.3.tar.gz 51606089 SHA256 a0a5dc39f785014f2088fed2c6d2d129f0444f71afbb9c44f7bdf1b14d86ebbc SHA512 553be9f661a1923d8ec7504a11dd3317e5ffb429c19339c58047715f4c28358d6d2ac38d46bd27ecd1dcf7159f157aab80d90713fbc4071e2e395bbf11ee6385 WHIRLPOOL 7e2b0472bb7d913e78260da95c93c3243562e76352790318286e5d194f88ac05a9f51fa029a7b0ad17bbbbd0dc9658769fe6301b544ec03f1ab5c205835ea894
 DIST matplotlib-2.0.2.tar.gz 53879938 SHA256 0ffbc44faa34a8b1704bc108c451ecf87988f900ef7ce757b8e2e84383121ff1 SHA512 39d68aee87fac2c246cdee7941ffaae1b8d586fa75c351bc94f963def66df32c3aba13fa0be94e1f8d21f06e068565b1a79c6d4f65589d8dd23cd48b32ab474f WHIRLPOOL 5ab8f9edb4591205d61bd47c5125520c0d24b8ce44e0041b99a5a0c692ffd3ff581cd6e092d18a64ddf6fb4f43ace6ee8c2bce19f5acd01d022d8a46e472b2df
+DIST matplotlib-2.1.0.tar.bz2 33051088 SHA256 0ab32ed55311dccdb42a488e1e7be5029695adf9219bc2b545ee0443dcf365c7 SHA512 872ff86e989b4e9352663f4abde1768aa05b1adea3e1b234efdb301429d421718314b27950e508d92df8fc9136764b07e8a6861b66512e9695a496993076bb5f WHIRLPOOL 0fb7d7e7e2b45ca6ae9ece32fa413f9c5b47fc59f64b877fad1f8becff4828a3be948f6433222008256c469b7760075c1d694b13ea771dfcd4193c2cda405aa6
 DIST matplotlib-2.1.0.tar.gz 35727251 SHA256 4b5f16c9cefde553ea79975305dcaa67c8e13d927b6e55aa14b4a8d867e25387 SHA512 8f512400f1f15d5400e23dd8e402783c54f62567d412863530a982c6513206d49fb91fadb3ef477648a4a38d6dd032eb90741ff4495d2be71911f83677d768b4 WHIRLPOOL 4795f3d49e3a624a22debe738cbe42ce3594c91880b3e6273f7ee05ecb7016353550cb39367f1edc6588d0e75d227d79f29af709e9471147171dd7ea5b6aa687
diff --git a/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild b/dev-python/matplotlib/matplotlib-2.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..db96f8c
--- /dev/null
@@ -0,0 +1,249 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
+
+DESCRIPTION="Pure python plotting library with matlab like syntax"
+HOMEPAGE="http://matplotlib.org/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+
+SLOT="0"
+# Main license: matplotlib
+# Some modules: BSD
+# matplotlib/backends/qt4_editor: MIT
+# Fonts: BitstreamVera, OFL-1.1
+LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="cairo doc excel examples gtk2 gtk3 latex pyside qt5 test tk wxwidgets"
+
+PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
+REQUIRED_USE="
+       doc? ( ${PY2_FLAGS} )
+       excel? ( ${PY2_FLAGS} )
+       gtk2? ( ${PY2_FLAGS} )
+       wxwidgets? ( ${PY2_FLAGS} )
+       test? (
+               cairo latex qt5 tk wxwidgets
+               || ( gtk2 gtk3 )
+               )"
+
+# #456704 -- a lot of py2-only deps
+PY2_USEDEP=$(python_gen_usedep python2_7)
+COMMON_DEPEND="
+       dev-python/cycler[${PYTHON_USEDEP}]
+       dev-python/functools32[${PY2_USEDEP}]
+       >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+       dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10[${PYTHON_USEDEP}]
+       dev-python/subprocess32[${PY2_USEDEP}]
+       media-fonts/stix-fonts
+       media-libs/freetype:2
+       media-libs/libpng:0
+       >=media-libs/qhull-2013
+       cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
+       gtk2? (
+               dev-libs/glib:2=
+               x11-libs/gdk-pixbuf
+               x11-libs/gtk+:2
+               dev-python/pygtk[${PY2_USEDEP}] )
+       wxwidgets? ( >=dev-python/wxpython-2.8:*[${PY2_USEDEP}] )"
+
+# internal copy of pycxx highly patched
+#      dev-python/pycxx
+
+DEPEND="${COMMON_DEPEND}
+       dev-python/versioneer[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       virtual/pkgconfig
+       doc? (
+               app-text/dvipng
+               dev-python/colorspacious[${PYTHON_USEDEP}]
+               dev-python/pillow[${PYTHON_USEDEP}]
+               dev-python/ipython[${PYTHON_USEDEP}]
+               dev-python/mock[${PY2_USEDEP}]
+               dev-python/numpydoc[${PYTHON_USEDEP}]
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/xlwt[${PYTHON_USEDEP}]
+               dev-texlive/texlive-latexextra
+               dev-texlive/texlive-fontsrecommended
+               dev-texlive/texlive-latexrecommended
+               media-gfx/graphviz[cairo]
+       )
+       test? (
+               dev-python/backports-functools-lru-cache[${PY2_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
+               )"
+
+RDEPEND="${COMMON_DEPEND}
+       >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
+       excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
+       gtk3? (
+               dev-python/pygobject:3[${PYTHON_USEDEP}]
+               x11-libs/gtk+:3[introspection] )
+       latex? (
+               virtual/latex-base
+               app-text/ghostscript-gpl
+               app-text/dvipng
+               app-text/poppler[utils]
+               dev-texlive/texlive-fontsrecommended
+               dev-texlive/texlive-latexextra
+               dev-texlive/texlive-xetex
+       )
+       pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
+       qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )
+       "
+
+# A few C++ source files are written to srcdir.
+# Other than that, the ebuild shall be fit for out-of-source build.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+pkg_setup() {
+       unset DISPLAY # bug #278524
+}
+
+use_setup() {
+       local uword="${2:-${1}}"
+       if use ${1}; then
+               echo "${uword} = True"
+               echo "${uword}agg = True"
+       else
+               echo "${uword} = False"
+               echo "${uword}agg = False"
+       fi
+}
+
+python_prepare_all() {
+# Generates test failures, but fedora does it
+#      local PATCHES=(
+#              "${FILESDIR}"/${P}-unbundle-pycxx.patch
+#              "${FILESDIR}"/${P}-unbundle-agg.patch
+#      )
+#      rm -r agg24 CXX || die
+#      rm -r agg24 || die
+
+#      cat > lib/${PN}/externals/six.py <<-EOF
+#      from __future__ import absolute_import
+#      from six import *
+#      EOF
+
+       sed \
+               -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
+               -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
+               || die "sed pyparsing failed"
+
+       hprefixify setupext.py
+
+       export XDG_RUNTIME_DIR="${T}/runtime-dir"
+       mkdir "${XDG_RUNTIME_DIR}" || die
+       chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+       append-flags -fno-strict-aliasing
+       append-cppflags -DNDEBUG  # or get old trying to do triangulation
+       tc-export PKG_CONFIG
+}
+
+python_configure() {
+       mkdir -p "${BUILD_DIR}" || die
+
+       # create setup.cfg (see setup.cfg.template for any changes).
+
+       # common switches.
+       cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
+               [directories]
+               basedirlist = ${EPREFIX}/usr
+               [provide_packages]
+               pytz = False
+               dateutil = False
+               [packages]
+               tests = $(usex test True False)
+               [gui_support]
+               agg = True
+               qt4 = False
+               qt4agg = False
+               $(use_setup cairo)
+               $(use_setup gtk3)
+               $(use_setup pyside)
+               $(use_setup qt5)
+               $(use_setup tk)
+       EOF
+
+       if use gtk3 && use cairo; then
+               echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
+       else
+               echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
+       fi
+
+       if python_is_python3; then
+               cat >> "${BUILD_DIR}"/setup.cfg <<- EOF || die
+                       gtk = False
+                       gtkagg = False
+                       wx = False
+                       wxagg = False
+               EOF
+       else
+               cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
+                       $(use_setup gtk2 gtk)
+                       $(use_setup wxwidgets wx)
+               EOF
+       fi
+}
+
+wrap_setup() {
+       local -x MPLSETUPCFG=${BUILD_DIR}/setup.cfg
+       unset DISPLAY
+       "$@"
+}
+
+python_compile() {
+       wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
+}
+
+python_compile_all() {
+       if use doc; then
+               cd doc || die
+
+               # necessary for in-source build
+               local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
+
+               VARTEXFONTS="${T}"/fonts \
+               "${EPYTHON}" ./make.py --small html || die
+       fi
+}
+
+python_test() {
+       wrap_setup distutils_install_for_testing
+
+       virtx "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)"
+}
+
+python_install() {
+       wrap_setup distutils-r1_python_install
+
+       # mpl_toolkits namespace
+       python_moduleinto mpl_toolkits
+       python_domodule lib/mpl_toolkits/__init__.py
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+
+       distutils-r1_python_install_all
+
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
+       find "${D}" -name '*.pth' -delete || die
+}