sys-libs/glibc: cross-*: pass EPREFIX to --with-headers
authorBenda Xu <heroxbd@gentoo.org>
Wed, 25 Dec 2019 09:28:55 +0000 (17:28 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Wed, 25 Dec 2019 10:57:58 +0000 (18:57 +0800)
  This is a follow up of ea4cbdc9159c0ebbd29d4062bbb314393a8cc32f.

  Otherwise when building cross toolchain on Gentoo Prefix, configure cannot
  find the needed linux-headers.

Bug: https://bugs.gentoo.org/642604
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
sys-libs/glibc/glibc-2.30-r3.ebuild
sys-libs/glibc/glibc-9999.ebuild

index 7bbdf0c882ad221512eb2ce34838cc97c6b03f8d..393684b8a8b30b574ec24e60aae37765d3edca3b 100644 (file)
@@ -929,7 +929,7 @@ glibc_do_configure() {
                --host=${CTARGET_OPT:-${CTARGET}}
                $(use_enable profile)
                $(use_with gd)
-               --with-headers=$(alt_build_headers)
+               --with-headers=$(build_eprefix)$(alt_build_headers)
                --prefix="$(host_eprefix)/usr"
                --sysconfdir="$(host_eprefix)/etc"
                --localstatedir="$(host_eprefix)/var"
@@ -1084,7 +1084,7 @@ glibc_headers_configure() {
                --enable-bind-now
                --build=${CBUILD_OPT:-${CBUILD}}
                --host=${CTARGET_OPT:-${CTARGET}}
-               --with-headers=$(alt_build_headers)
+               --with-headers=$(build_eprefix)$(alt_build_headers)
                --prefix="$(host_eprefix)/usr"
                ${EXTRA_ECONF}
        )
index a3d9d33a3686ceb2b48bfd61a6a2bc6f467d583f..94ff23bb27e87825bf781ab29b6b205e905bf14d 100644 (file)
@@ -929,7 +929,7 @@ glibc_do_configure() {
                --host=${CTARGET_OPT:-${CTARGET}}
                $(use_enable profile)
                $(use_with gd)
-               --with-headers=$(alt_build_headers)
+               --with-headers=$(build_eprefix)$(alt_build_headers)
                --prefix="$(host_eprefix)/usr"
                --sysconfdir="$(host_eprefix)/etc"
                --localstatedir="$(host_eprefix)/var"
@@ -1084,7 +1084,7 @@ glibc_headers_configure() {
                --enable-bind-now
                --build=${CBUILD_OPT:-${CBUILD}}
                --host=${CTARGET_OPT:-${CTARGET}}
-               --with-headers=$(alt_build_headers)
+               --with-headers=$(build_eprefix)$(alt_build_headers)
                --prefix="$(host_eprefix)/usr"
                ${EXTRA_ECONF}
        )