dev-libs/apr: fix building with GCC8, fix tests
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 28 Aug 2018 11:53:25 +0000 (13:53 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 28 Aug 2018 11:53:25 +0000 (13:53 +0200)
Closes: https://bugs.gentoo.org/635434
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-libs/apr/apr-1.6.3-r2.ebuild [new file with mode: 0644]
dev-libs/apr/files/apr-1.6.3-fix-overflow-check-in-overflow_strfsize.patch [new file with mode: 0644]

diff --git a/dev-libs/apr/apr-1.6.3-r2.ebuild b/dev-libs/apr/apr-1.6.3-r2.ebuild
new file mode 100644 (file)
index 0000000..a874140
--- /dev/null
@@ -0,0 +1,153 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools libtool ltprune multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="https://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1/${PV%.*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility selinux static-libs +urandom"
+
+CDEPEND="elibc_glibc? ( >=sys-apps/util-linux-2.16 )
+       elibc_mintlib? ( >=sys-apps/util-linux-2.18 )"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-apache )"
+DEPEND="${CDEPEND}
+       >=sys-devel/libtool-2.4.2
+       doc? ( app-doc/doxygen )"
+
+DOCS=( CHANGES NOTICE README )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.5.0-mint.patch
+       "${FILESDIR}"/${PN}-1.5.0-libtool.patch
+       "${FILESDIR}"/${PN}-1.5.0-cross-types.patch
+       "${FILESDIR}"/${PN}-1.5.0-sysroot.patch #385775
+       "${FILESDIR}"/${PN}-1.6.3-fix-overflow-check-in-overflow_strfsize.patch
+)
+
+src_prepare() {
+       default
+
+       mv configure.in configure.ac || die
+       AT_M4DIR="build" eautoreconf
+       elibtoolize
+
+       eapply "${FILESDIR}/config.layout.patch"
+}
+
+src_configure() {
+       local myconf=(
+               --enable-layout=gentoo
+               --enable-nonportable-atomics
+               --enable-posix-shm
+               --enable-threads
+               $(use_enable static-libs static)
+       )
+
+       [[ ${CHOST} == *-mint* ]] && export ac_cv_func_poll=no
+
+       if use older-kernels-compatibility; then
+               local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
+               export apr_cv_accept4="no"
+               export apr_cv_dup3="no"
+               export apr_cv_epoll_create1="no"
+               export apr_cv_sock_cloexec="no"
+       fi
+       if tc-is-cross-compiler; then
+               # The apache project relies heavily on AC_TRY_RUN and doesn't
+               # have any sane cross-compiling fallback logic.
+               export \
+                       ac_cv_file__dev_zero="yes" \
+                       ac_cv_func_sem_open="yes" \
+                       ac_cv_negative_eai="yes" \
+                       ac_cv_o_nonblock_inherited="no" \
+                       ac_cv_struct_rlimit="yes" \
+                       ap_cv_atomic_builtins="yes" \
+                       apr_cv_accept4="yes" \
+                       apr_cv_dup3="yes" \
+                       apr_cv_epoll="yes" \
+                       apr_cv_epoll_create1="yes" \
+                       apr_cv_gai_addrconfig="yes" \
+                       apr_cv_mutex_recursive="yes" \
+                       apr_cv_mutex_robust_shared="yes" \
+                       apr_cv_process_shared_works="yes" \
+                       apr_cv_pthreads_lib="-pthread" \
+                       apr_cv_sock_cloexec="yes" \
+                       apr_cv_tcp_nodelay_with_cork="yes"
+       fi
+
+       if use urandom; then
+               myconf+=( --with-devrandom=/dev/urandom )
+       elif (( ${CHOST#*-hpux11.} <= 11 )); then
+               : # no /dev/*random on hpux11.11 and before, $PN detects this.
+       else
+               myconf+=( --with-devrandom=/dev/random )
+       fi
+
+       tc-is-static-only && myconf+=( --disable-dso )
+
+       # shl_load does not search runpath, but hpux11 supports dlopen
+       [[ ${CHOST} == *-hpux11* ]] && myconf+=( --enable-dso=dlfcn )
+
+       if [[ ${CHOST} == *-solaris2.10 ]]; then
+               case $(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h) in
+               *atomic_cas_ptr*) ;;
+               *)
+                       elog "You do not have Solaris Patch ID "$(
+                               [[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885
+                       )" (Problem 4954703) installed on your host ($(hostname)),"
+                       elog "using generic atomic operations instead."
+                       myconf+=( --disable-nonportable-atomics )
+                       ;;
+               esac
+       fi
+
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       if tc-is-cross-compiler; then
+               # This header is the same across targets, so use the build compiler.
+               emake tools/gen_test_char
+               tc-export_build_env BUILD_CC
+               ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
+                       tools/gen_test_char.c -o tools/gen_test_char || die
+       fi
+
+       emake
+
+       if use doc; then
+               emake dox
+       fi
+}
+
+src_test() {
+       # Building tests in parallel is broken
+       emake -j1 check
+}
+
+src_install() {
+       default
+
+       # Prallel install breaks since apr-1.5.1
+       #make -j1 DESTDIR="${D}" install || die
+
+       prune_libtool_files --all
+
+       if use doc; then
+               docinto html
+               dodoc -r docs/dox/html/*
+       fi
+
+       # This file is only used on AIX systems, which Gentoo is not,
+       # and causes collisions between the SLOTs, so remove it.
+       # Even in Prefix, we don't need this on AIX.
+       rm -f "${ED%/}/usr/$(get_libdir)/apr.exp"
+}
diff --git a/dev-libs/apr/files/apr-1.6.3-fix-overflow-check-in-overflow_strfsize.patch b/dev-libs/apr/files/apr-1.6.3-fix-overflow-check-in-overflow_strfsize.patch
new file mode 100644 (file)
index 0000000..d6e1f54
--- /dev/null
@@ -0,0 +1,21 @@
+https://bz.apache.org/bugzilla/show_bug.cgi?id=62056
+
+--- apr-1.6.3.orig/test/teststr.c
++++ apr-1.6.3.orig/test/teststr.c
+@@ -307,10 +307,15 @@ 
+     for (; off < 999999999; off += 999) {
+         apr_strfsize(off, buf);
+     }
+-    for (off = 1; off < LONG_MAX && off > 0; off *= 2) {
++
++    off = 1;
++    while (1) {
+         apr_strfsize(off, buf);
+         apr_strfsize(off + 1, buf);
+         apr_strfsize(off - 1, buf);
++        if (off > LONG_MAX / 2)
++            break;
++        off *= 2;
+     }
+     ABTS_ASSERT(tc, "strfsize overflowed", buf[5] == '$');