app-misc/mosquitto: Version bump to 1.6.8
authorMatt Turner <mattst88@gentoo.org>
Fri, 20 Dec 2019 20:40:59 +0000 (15:40 -0500)
committerMatt Turner <mattst88@gentoo.org>
Fri, 20 Dec 2019 21:58:53 +0000 (16:58 -0500)
Closes: https://bugs.gentoo.org/696946
Closes: https://bugs.gentoo.org/700816
Signed-off-by: Matt Turner <mattst88@gentoo.org>
app-misc/mosquitto/Manifest
app-misc/mosquitto/mosquitto-1.6.8.ebuild [new file with mode: 0644]

index ae2670ea268db49c755383060c137921435ba7de..430e2c8db3b9642e12cc30149884f637dcd506ff 100644 (file)
@@ -1 +1,2 @@
 DIST mosquitto-1.6.7.tar.gz 591062 BLAKE2B a215e311197fd84f1fa1ff0b681c8d1157db1a3e538a5a16afa1f11d17a08a720d44ae16b306cb08d6b585c8c4d4b2e38df972ceebc4634c727f4c8e0994c170 SHA512 0a75cf192483053ce78c6d9e3be158bdf66366d7731a68cf29e24731f6936027af1d86045c2b973f642e42e58efa033dbfd17842e3e95550bac4c1f44ab346e9
+DIST mosquitto-1.6.8.tar.gz 589873 BLAKE2B aa2e13397f7d4b6305af3180cd042cd143054e154cf8e6d93b05bc5a10d48419174711a1893fe60c1303a2f83cfbc5341cf03ec595e3640f503a2407e869491b SHA512 c15897df4e0979ee29a1e67cc671f56db600a078e9eb0bea376248b3f53b13ceed36616ad3678e2c9e07d6834a6d75e4efca2c40086069c1546e0223be04c071
diff --git a/app-misc/mosquitto/mosquitto-1.6.8.ebuild b/app-misc/mosquitto/mosquitto-1.6.8.ebuild
new file mode 100644 (file)
index 0000000..25f2cf6
--- /dev/null
@@ -0,0 +1,114 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="https://mosquitto.org/"
+SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bridge examples libressl +persistence +srv ssl tcpd test websockets"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="
+       acct-user/mosquitto
+       acct-group/mosquitto
+       srv? ( net-dns/c-ares:= )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+       tcpd? ( sys-apps/tcp-wrappers )"
+
+DEPEND="${PYTHON_DEPS}
+       ${RDEPEND}
+       test? ( dev-util/cunit )
+       websockets? ( net-libs/libwebsockets[lejp] )"
+
+_emake() {
+       local LIBDIR=$(get_libdir)
+       emake \
+               CC="$(tc-getCC)" \
+               CLIENT_LDFLAGS="${LDFLAGS}" \
+               LIB_SUFFIX="${LIBDIR:3}" \
+               WITH_BRIDGE="$(usex bridge)" \
+               WITH_PERSISTENCE="$(usex persistence)" \
+               WITH_SRV="$(usex srv)" \
+               WITH_TLS="$(usex ssl)" \
+               WITH_WEBSOCKETS="$(usex websockets)" \
+               WITH_WRAP="$(usex tcpd)" \
+               "$@"
+}
+
+src_prepare() {
+       default
+       if use persistence; then
+               sed -i -e "/^#autosave_interval/s|^#||" \
+                       -e "s|^#persistence false$|persistence true|" \
+                       -e "/^#persistence_file/s|^#||" \
+                       -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+                       mosquitto.conf || die
+       fi
+
+       # Remove prestripping
+       sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
+               client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
+
+       # Remove failing tests
+       sed -i -e '/02-subpub-qos1-bad-pubcomp.py/d' \
+               -e '/02-subpub-qos1-bad-pubrec.py/d' \
+               -e '/02-subpub-qos2-bad-puback-1.py/d' \
+               -e '/02-subpub-qos2-bad-puback-2.py/d' \
+               -e '/02-subpub-qos2-bad-pubcomp.py/d' \
+               test/broker/Makefile || die
+       sed -i -e '/02-subscribe-qos1-async2.test/d' \
+               test/lib/Makefile || die
+
+       python_setup
+       python_fix_shebang test
+}
+
+src_compile() {
+       _emake
+}
+
+src_test() {
+       _emake test
+}
+
+src_install() {
+       _emake DESTDIR="${D}" prefix=/usr install
+       keepdir /var/lib/mosquitto
+       fowners mosquitto:mosquitto /var/lib/mosquitto
+       dodoc readme.md CONTRIBUTING.md ChangeLog.txt
+       doinitd "${FILESDIR}"/mosquitto
+       insinto /etc/mosquitto
+       doins mosquitto.conf
+       systemd_dounit "${FILESDIR}/mosquitto.service"
+
+       if use examples; then
+               docompress -x "/usr/share/doc/${PF}/examples"
+               dodoc -r examples
+       fi
+}
+
+pkg_postinst() {
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               elog "The Python module has been moved out of mosquitto."
+               elog "See https://mosquitto.org/documentation/python/"
+       else
+               elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
+               elog ""
+               elog "    rc-update add mosquitto default"
+               elog "or"
+               elog "    systemctl enable mosquitto"
+       fi
+}