dev-python/manuel: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 10 Aug 2018 18:45:00 +0000 (20:45 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 11 Aug 2018 22:39:42 +0000 (00:39 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/manuel/Manifest
dev-python/manuel/manuel-1.9.0.ebuild [new file with mode: 0644]

index 146027d12ade3e7a7ab9e9cb62061c4f1ac6d340..5e2344a9aad03d160199b081c7c00d3ba904cbea 100644 (file)
@@ -1 +1,2 @@
 DIST manuel-1.8.0.tar.gz 207600 BLAKE2B f7bad36491d49254c7aea17550cbd4fa00b6c3c122061586785da4bddc514f51a2d5a8df3b048fe78c7b01036ca903330ea614c998fdd04d1e8cca002930c962 SHA512 8099df44cfd28c8ac6256f346bf8cd36091893a38d3c297099866b1a5db97286b9c9e69f3f12054d7eee9ae3985ca0a003d7b2cc082d28d59850bbcad6b57c57
+DIST manuel-1.9.0.tar.gz 39640 BLAKE2B 1b699b92816297fee13a65ed2c4fc9ee3683f8e47e7fbf06178c97167ae29cabcedc48edec48b053f725889b39111b3634f0305ac651b5674292d046434fd134 SHA512 519b0fd1bd7ef3414dec69f721a6f1265603d28e3b61681acf46e9fba6fdc66efb6c0a82d814af8348bb7c07c3c4c299ae94ea7d6415436592ac37fccaacf18a
diff --git a/dev-python/manuel/manuel-1.9.0.ebuild b/dev-python/manuel/manuel-1.9.0.ebuild
new file mode 100644 (file)
index 0000000..516294c
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Manuel lets you build tested documentation"
+HOMEPAGE="https://github.com/benji-york/manuel/ https://pypi.org/project/manuel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+       ${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Required to run tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+#DOCS=( CHANGES.rst )
+
+#PATCHES=( "${FILESDIR}"/${P}-rm_zope_test.patch )
+
+#python_test() {
+#      PYTHONPATH=src/:${PYTHONPATH} esetup.py test
+#}