media-sound/mpg123: Security cleanup
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 20 Sep 2018 13:09:32 +0000 (15:09 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 20 Sep 2018 15:22:33 +0000 (17:22 +0200)
Bug: https://bugs.gentoo.org/626346
Package-Manager: Portage-2.3.49, Repoman-2.3.10

media-sound/mpg123/Manifest
media-sound/mpg123/mpg123-1.25.6.ebuild [deleted file]
media-sound/mpg123/mpg123-1.25.8.ebuild [deleted file]

index 265c7ddf66eb3d7be2d67a396ade959a49a968c1..c15d548f4da4fb2a66d50bce67a29a9e3618804e 100644 (file)
@@ -1,3 +1 @@
 DIST mpg123-1.25.10.tar.bz2 921219 BLAKE2B 04bfbe8915e3943ed42cc2d3597b0bd9c4686f77ee699f5845e7d1e905022206724cf23d6b0420a36e64b232f840dd9367f46f3c00dc2fe6256f44e8b83fa5b2 SHA512 a33666ae4aca7e7c1a93a6414d8c525ec19044c54f712d578180147d88e63033f7af2370b9ad22960cc3a0b454f15967b7a831cccc97e034c8855f70cdf1ab09
-DIST mpg123-1.25.6.tar.bz2 919169 BLAKE2B 7b330d67465f332f608fa7efbfbfe1bbe69f8912a5678f72c56080b2deb44407d66bac6af23fb8c1359373eb90966ba67901235555f1776a00dc27e66167b0a5 SHA512 0b129c38c19462f7fbe3f56ea2b856222f8a1a3ba76ef8109ca759c9a9c668432cc0ec76059f9a7a3c37228ce615e4c628c7de3b1663073302cc7c8fc93f249c
-DIST mpg123-1.25.8.tar.bz2 920677 BLAKE2B bbffa9fa36c40557abb6c70af942b63a43739462c86a22839363b36a39e1a2f16ce3f4e5462f9be9cea2addda1b46af6fdd58b24b5a0b31949efc604ef475c19 SHA512 f226317dddb07841a13753603fa13c0a867605a5a051626cb30d45cfba266d3d4296f5b8254f65b403bb5eef6addce1784ae8829b671a746854785cda1bad203
diff --git a/media-sound/mpg123/mpg123-1.25.6.ebuild b/media-sound/mpg123/mpg123-1.25.6.ebuild
deleted file mode 100644 (file)
index 39a7bcf..0000000
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic toolchain-funcs libtool multilib-minimal
-
-DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
-HOMEPAGE="https://www.mpg123.org/"
-SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext alsa altivec coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
-
-# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
-RDEPEND="app-eselect/eselect-mpg123
-       dev-libs/libltdl:0
-       alsa? ( media-libs/alsa-lib )
-       jack? ( virtual/jack )
-       nas? ( media-libs/nas )
-       portaudio? ( media-libs/portaudio )
-       pulseaudio? ( media-sound/pulseaudio )
-       sdl? ( media-libs/libsdl )"
-DEPEND="${RDEPEND}
-       sys-devel/libtool
-       virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
-
-pkg_setup() {
-       # Build fails without -D_GNU_SOURCE like this:
-       # error: ‘struct hostent’ has no member named ‘h_addr’
-       append-cflags -D_GNU_SOURCE
-}
-
-src_prepare() {
-       default
-       elibtoolize # for Darwin bundles
-}
-
-multilib_src_configure() {
-       local _audio=dummy
-       local _output=dummy
-       local _cpu=generic_fpu
-
-       if $(multilib_is_native_abi) ; then
-               for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
-                       if use ${flag}; then
-                               _audio+=" ${flag/pulseaudio/pulse}"
-                               _output=${flag/pulseaudio/pulse}
-                       fi
-               done
-       fi
-
-       use altivec && _cpu=altivec
-
-       if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
-               use cpu_flags_x86_sse && _cpu=x86-64
-       elif use x86 && gcc-specs-pie ; then
-               # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
-               _cpu=generic_fpu
-       elif use x86-macos ; then
-               # ASM doesn't work quite as expected with the Darwin linker
-               _cpu=generic_fpu
-       else
-               use cpu_flags_x86_mmx && _cpu=mmx
-               use cpu_flags_x86_3dnow && _cpu=3dnow
-               use cpu_flags_x86_sse && _cpu=x86
-               use cpu_flags_x86_3dnowext && _cpu=x86
-       fi
-
-       local myconf=""
-       multilib_is_native_abi || myconf="${myconf} --disable-modules"
-
-       ECONF_SOURCE="${S}" econf \
-               --with-optimization=0 \
-               --with-audio="${_audio}" \
-               --with-default-audio=${_output} \
-               --with-cpu=${_cpu} \
-               --enable-network \
-               $(use_enable ipv6) \
-               --enable-int-quality=$(usex int-quality) \
-               ${myconf}
-
-       if ! $(multilib_is_native_abi) ; then
-               sed -i -e 's:src doc:src/libmpg123:' Makefile || die
-       fi
-}
-
-multilib_src_install_all() {
-       einstalldocs
-       mv "${ED}"/usr/bin/mpg123{,-mpg123}
-       find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
-}
-
-pkg_postinst() {
-       eselect mpg123 update ifunset
-}
-
-pkg_postrm() {
-       eselect mpg123 update ifunset
-}
diff --git a/media-sound/mpg123/mpg123-1.25.8.ebuild b/media-sound/mpg123/mpg123-1.25.8.ebuild
deleted file mode 100644 (file)
index 5cb30be..0000000
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic toolchain-funcs libtool multilib-minimal
-
-DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
-HOMEPAGE="https://www.mpg123.org/"
-SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext alsa altivec coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
-
-# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
-RDEPEND="app-eselect/eselect-mpg123
-       dev-libs/libltdl:0
-       alsa? ( media-libs/alsa-lib )
-       jack? ( virtual/jack )
-       nas? ( media-libs/nas )
-       portaudio? ( media-libs/portaudio )
-       pulseaudio? ( media-sound/pulseaudio )
-       sdl? ( media-libs/libsdl )"
-DEPEND="${RDEPEND}
-       sys-devel/libtool
-       virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
-
-pkg_setup() {
-       # Build fails without -D_GNU_SOURCE like this:
-       # error: ‘struct hostent’ has no member named ‘h_addr’
-       append-cflags -D_GNU_SOURCE
-}
-
-src_prepare() {
-       default
-       elibtoolize # for Darwin bundles
-}
-
-multilib_src_configure() {
-       local _audio=dummy
-       local _output=dummy
-       local _cpu=generic_fpu
-
-       if $(multilib_is_native_abi) ; then
-               for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
-                       if use ${flag}; then
-                               _audio+=" ${flag/pulseaudio/pulse}"
-                               _output=${flag/pulseaudio/pulse}
-                       fi
-               done
-       fi
-
-       use altivec && _cpu=altivec
-
-       if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
-               use cpu_flags_x86_sse && _cpu=x86-64
-       elif use x86 && gcc-specs-pie ; then
-               # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
-               _cpu=generic_fpu
-       elif use x86-macos ; then
-               # ASM doesn't work quite as expected with the Darwin linker
-               _cpu=generic_fpu
-       else
-               use cpu_flags_x86_mmx && _cpu=mmx
-               use cpu_flags_x86_3dnow && _cpu=3dnow
-               use cpu_flags_x86_sse && _cpu=x86
-               use cpu_flags_x86_3dnowext && _cpu=x86
-       fi
-
-       local myconf=""
-       multilib_is_native_abi || myconf="${myconf} --disable-modules"
-
-       ECONF_SOURCE="${S}" econf \
-               --with-optimization=0 \
-               --with-audio="${_audio}" \
-               --with-default-audio=${_output} \
-               --with-cpu=${_cpu} \
-               --enable-network \
-               $(use_enable ipv6) \
-               --enable-int-quality=$(usex int-quality) \
-               ${myconf}
-
-       if ! $(multilib_is_native_abi) ; then
-               sed -i -e 's:src doc:src/libmpg123:' Makefile || die
-       fi
-}
-
-multilib_src_install_all() {
-       einstalldocs
-       mv "${ED}"/usr/bin/mpg123{,-mpg123}
-       find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
-}
-
-pkg_postinst() {
-       eselect mpg123 update ifunset
-}
-
-pkg_postrm() {
-       eselect mpg123 update ifunset
-}