Version bump thanks to Vieri <rentorbuy@yahoo.com> in bug 137246
authorStefan Schweizer <genstef@gentoo.org>
Mon, 19 Jun 2006 19:53:55 +0000 (19:53 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Mon, 19 Jun 2006 19:53:55 +0000 (19:53 +0000)
Package-Manager: portage-2.1.1_pre1-r1

net-print/cups-pdf/ChangeLog
net-print/cups-pdf/cups-pdf-2.4.1.ebuild [new file with mode: 0644]
net-print/cups-pdf/files/digest-cups-pdf-2.4.1 [new file with mode: 0644]

index 1a27a6dd6a22b3aea176218aaa46743f5bdd3b89..69a85cd1d02bdc16f0ad0d5de906b5f3021b62bd 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-print/cups-pdf
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/ChangeLog,v 1.25 2006/05/30 11:45:56 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/ChangeLog,v 1.26 2006/06/19 19:53:55 genstef Exp $
+
+*cups-pdf-2.4.1 (19 Jun 2006)
+
+  19 Jun 2006; Stefan Schweizer <genstef@gentoo.org> -cups-pdf-2.2.0.ebuild,
+  -cups-pdf-2.4.0.ebuild, +cups-pdf-2.4.1.ebuild:
+  Version bump thanks to Vieri <rentorbuy@yahoo.com> in bug 137246
 
 *cups-pdf-2.4.0 (29 May 2006)
 
diff --git a/net-print/cups-pdf/cups-pdf-2.4.1.ebuild b/net-print/cups-pdf/cups-pdf-2.4.1.ebuild
new file mode 100644 (file)
index 0000000..297c475
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/cups-pdf-2.4.1.ebuild,v 1.1 2006/06/19 19:53:55 genstef Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files."
+HOMEPAGE="http://cip.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/"
+SRC_URI="http://cip.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/src/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-print/cups
+       virtual/ghostscript"
+
+src_compile() {
+       cd src
+       $(tc-getCC) ${CFLAGS} -o cups-pdf cups-pdf.c || die "Compilation failed."
+}
+
+src_install () {
+       exeinto $(cups-config --serverbin)/backend
+       has_version '>=net-print/cups-1.2*' && exeopts -m0700
+       doexe src/cups-pdf
+
+       insinto /usr/share/cups/model
+       doins extra/PostscriptColor_rev3b.ppd.gz
+       doins extra/PostscriptColor_rev4.ppd.gz
+       dosym PostscriptColor_rev3b.ppd.gz /usr/share/cups/model/PostscriptColor.ppd.gz
+
+       insinto /etc/cups
+       doins extra/cups-pdf.conf
+
+       dodoc ChangeLog README
+       newdoc contrib/Contents contrib_Contents
+}
+
+pkg_postinst () {
+       einfo "Please view both the README and contrib_Contents files"
+       einfo "as you may want to adjust some settings and/or use"
+       einfo "contributed software. In the latter case you may need"
+       einfo "to extract some files from the ${P} distfile."
+}
diff --git a/net-print/cups-pdf/files/digest-cups-pdf-2.4.1 b/net-print/cups-pdf/files/digest-cups-pdf-2.4.1
new file mode 100644 (file)
index 0000000..9254cc3
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4cef6dd76d09dc2f7f3df133ef339b52 cups-pdf_2.4.1.tar.gz 50448
+RMD160 e9216836706ab2ca925bc34b736f9bbc9a2caac4 cups-pdf_2.4.1.tar.gz 50448
+SHA256 9b44b84c28d15f48e0ca0ae5191f0df5bc5600a72118a4ed29fee8a0812fa59b cups-pdf_2.4.1.tar.gz 50448