media-video/vamps: EAPI 7
authorSebastian Pipping <sping@gentoo.org>
Sun, 27 Oct 2019 13:40:29 +0000 (14:40 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sun, 27 Oct 2019 13:41:01 +0000 (14:41 +0100)
Bug: https://bugs.gentoo.org/697264
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.78, Repoman-2.3.16

media-video/vamps/vamps-0.99.2-r2.ebuild [new file with mode: 0644]

diff --git a/media-video/vamps/vamps-0.99.2-r2.ebuild b/media-video/vamps/vamps-0.99.2-r2.ebuild
new file mode 100644 (file)
index 0000000..7167705
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Very fast requantisizing tool for backup DVDs"
+HOMEPAGE="http://vamps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vamps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libdvdread-0.9.4"
+RDEPEND="${DEPEND}
+       >=media-video/dvdauthor-0.6.10"
+
+PATCHES=(
+       "${FILESDIR}/${P}-premature-eof.patch"
+)
+
+src_compile() {
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       dobin vamps/vamps play_cell/play_cell
+}