x11-misc/mate-notification-daemon: Bump to 1.24.0
authorAdam Feldman <NP-Hardass@gentoo.org>
Sun, 22 Mar 2020 17:24:34 +0000 (13:24 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:48:20 +0000 (13:48 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
x11-misc/mate-notification-daemon/Manifest
x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild [new file with mode: 0644]

index 06adb6fd4393c7c1afbe5bd80ef42a7fa4c12e85..ecf3d46f405c69bb11ec6bb8f547dcffc5c1ed8f 100644 (file)
@@ -1,2 +1,3 @@
 DIST mate-notification-daemon-1.22.0.tar.xz 360676 BLAKE2B 0eb50a6179b5b90243e8206bbbb6c3ce1bf65cf3b2969e0c259e4bdebdf6e86d769f74020509cc170b087a02c6295007f83efc950407f803be6e717b0fc900ae SHA512 1345604dee1315843ad5a6920aab7cbe1544c8f7c7ccea686e5684c7ea5272fa09d27edbcc996f6a568f8b3760f561b84901c44f93f1b3ae2d5ddcd3c3ce86fc
 DIST mate-notification-daemon-1.22.1.tar.xz 340472 BLAKE2B 09a4fd8f14ffcde530bf3f95aa5d38f5ab1d105dd854464eb698fa3f42594e4559a48d034a0e25a021f2cd2382d02fbe357269636ea2603f940d666467ba4058 SHA512 5faec84a2c25b3d17db5e0e564081a5712a0ae9a648b61e7d6233f7c6671a137cb9e0d2328eccad4e634eb99cae72cf235589f3667b9bf29e66c3734f7ed8bc7
+DIST mate-notification-daemon-1.24.0.tar.xz 392588 BLAKE2B 480272848b3403d34eaa1f555a573dbf74a4e8e45e76c4726943bda4c29d7002f00d1a828e318d51dd07a44df1c64902c38bbe41c1c14339e8cb8710f7008f36 SHA512 0fd2da98001c60672d4833e974ac74dd561f54ca6f3fd74f8d6620e3b28768add46dd891d7446b01426b6aed09d4966d902cbde45aac3498fdcbb837e531a147
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.24.0.ebuild
new file mode 100644 (file)
index 0000000..b72fee0
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="dev-libs/atk
+       >=dev-libs/glib-2.50:2
+       >=sys-apps/dbus-1
+       x11-libs/cairo
+       >=x11-libs/gdk-pixbuf-2.22:2
+       >=x11-libs/libnotify-0.7
+       x11-libs/libX11
+       virtual/libintl
+       >=x11-libs/gtk+-3.22:3
+       >=x11-libs/libwnck-3:3
+       >=media-libs/libcanberra-0.4:0[gtk3]
+"
+
+RDEPEND="${COMMON_DEPEND}
+       virtual/libintl
+       !x11-misc/notify-osd
+       !x11-misc/qtnotifydaemon
+       !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+       app-arch/xz-utils
+       dev-libs/libxml2
+       dev-util/gdbus-codegen
+       >=sys-devel/gettext-0.19.8:*
+       >=sys-devel/libtool-2.2.6:2
+       virtual/pkgconfig:*"
+
+src_configure() {
+       mate_src_configure
+}
+
+src_install() {
+       mate_src_install
+
+       insinto /usr/share/dbus-1/services
+       doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}