app-misc/pip: revbump: EAPI 7, perl-module.eclass
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 17 Oct 2019 03:17:01 +0000 (05:17 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Thu, 17 Oct 2019 03:17:33 +0000 (05:17 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
app-misc/pip/pip-1.2-r3.ebuild [new file with mode: 0644]

diff --git a/app-misc/pip/pip-1.2-r3.ebuild b/app-misc/pip/pip-1.2-r3.ebuild
new file mode 100644 (file)
index 0000000..64323d9
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit perl-module
+
+DESCRIPTION="Wrapper around programs that don't support stdin/stdout"
+HOMEPAGE="http://membled.com/work/apps/pip/"
+SRC_URI="http://membled.com/work/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_install() {
+       perl-module_src_install
+       mv "${ED}"/usr/bin/{pip,gpip} || die 'rename failed'
+}
+
+pkg_postinst() {
+       ewarn "To avoid collisions with dev-python/pip executable file of this package was renamed to 'gpip'"
+}