net-misc/chrony: USE=html is not optional for the live ebuild, as the ADOC=true hack...
authorJeroen Roovers <jer@gentoo.org>
Sun, 6 Nov 2016 09:31:57 +0000 (10:31 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 6 Nov 2016 09:32:26 +0000 (10:32 +0100)
Package-Manager: portage-2.3.2

net-misc/chrony/chrony-9999.ebuild

index b744729dbdd81a738cefcaabcec55498b1ce303c..851dbdb9ddde40c412a7fcb21217e9d3e40c4b0f 100644 (file)
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
 SLOT="0"
 
 KEYWORDS=""
-IUSE="caps +cmdmon html ipv6 libedit +ntp +phc pps readline +refclock +rtc selinux +adns"
+IUSE="caps +cmdmon ipv6 libedit +ntp +phc pps readline +refclock +rtc selinux +adns"
 REQUIRED_USE="
        ?? ( libedit readline )
 "
@@ -25,7 +25,7 @@ CDEPEND="
 "
 DEPEND="
        ${CDEPEND}
-       html? ( dev-ruby/asciidoctor )
+       dev-ruby/asciidoctor
 "
 RDEPEND="
        ${CDEPEND}
@@ -40,7 +40,7 @@ src_prepare() {
        sed -i \
                -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
                -e 's:/var/run:/run:g' \
-               conf.c doc/*.man.in examples/* || die
+               conf.c doc/*.adoc examples/* || die
 
        default
 }
@@ -90,7 +90,7 @@ src_configure() {
 }
 
 src_compile() {
-       emake all docs $(usex html '' 'ADOC=true')
+       emake all docs
 }
 
 src_install() {
@@ -105,10 +105,8 @@ src_install() {
        docinto examples
        dodoc examples/*.example*
 
-       if use html; then
-               docinto html
-               dodoc doc/*.html
-       fi
+       docinto html
+       dodoc doc/*.html
 
        keepdir /var/{lib,log}/chrony