2.1_pre26 version bump for bug 157028. Thanks to Arthur Koziel <arthur.koziel at...
authorMarcelo Góes <vanquirius@gentoo.org>
Mon, 4 Dec 2006 01:29:52 +0000 (01:29 +0000)
committerMarcelo Góes <vanquirius@gentoo.org>
Mon, 4 Dec 2006 01:29:52 +0000 (01:29 +0000)
Package-Manager: portage-2.1.1-r2

www-client/links/ChangeLog
www-client/links/files/digest-links-2.1_pre26 [new file with mode: 0644]
www-client/links/links-2.1_pre26.ebuild [new file with mode: 0644]

index 234ff8a546528047902f8e87aa2bfff58adea127..ac7fa1451d94882b9c6783f487dc420e14205b64 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for www-client/links
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.73 2006/11/11 09:31:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.74 2006/12/04 01:29:52 vanquirius Exp $
+
+*links-2.1_pre26 (04 Dec 2006)
+
+  04 Dec 2006; Marcelo Goes <vanquirius@gentoo.org> -links-2.1_pre22.ebuild,
+  +links-2.1_pre26.ebuild:
+  2.1_pre26 version bump for bug 157028. Thanks to Arthur Koziel
+  <arthur.koziel at dkh-multigaming dot de>.
 
   11 Nov 2006; Mike Frysinger <vapier@gentoo.org>
   +files/configure-LANG.patch, links-2.1_pre23.ebuild:
diff --git a/www-client/links/files/digest-links-2.1_pre26 b/www-client/links/files/digest-links-2.1_pre26
new file mode 100644 (file)
index 0000000..35b153c
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 1f59217d4906622693eb3e1532871a72 links-2.1pre22-utf8.diff.bz2 4189
+RMD160 fa0c4719aa5ac0244bd165d010b9c303bfead5d3 links-2.1pre22-utf8.diff.bz2 4189
+SHA256 42982ee8f605f793226f07da9ed5cb9d5be613d1f8e4bb6270533bbd7cd42b9b links-2.1pre22-utf8.diff.bz2 4189
+MD5 841af2540c789e254b8465e07e24c684 links-2.1pre26.tar.bz2 3918490
+RMD160 8e7bbe0f8bb7d71d341405f524ebfb1c144b442b links-2.1pre26.tar.bz2 3918490
+SHA256 c89f10d42be2a0be8a017e1084897b1aabc5bca76817e9dab43b758dff051c56 links-2.1pre26.tar.bz2 3918490
diff --git a/www-client/links/links-2.1_pre26.ebuild b/www-client/links/links-2.1_pre26.ebuild
new file mode 100644 (file)
index 0000000..252d938
--- /dev/null
@@ -0,0 +1,127 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.1_pre26.ebuild,v 1.1 2006/12/04 01:29:52 vanquirius Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="links is a fast lightweight text and graphic web-browser"
+HOMEPAGE="http://links.twibright.com/"
+# To handle pre-version ...
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://links.twibright.com/download/${MY_P}.tar.bz2
+       mirror://gentoo/${PN}-2.1pre22-utf8.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="directfb fbcon gpm javascript jpeg livecd png sdl ssl svga tiff unicode X"
+
+# Note: if X or fbcon usegflag are enabled, links will be built in graphic
+# mode. libpng is required to compile links in graphic mode
+# (not required in text mode), so let's add libpng for X? and fbcon?
+
+# We've also made USE=livecd compile in graphics mode.  This closes bug #75685.
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6c )
+       gpm? ( sys-libs/gpm )
+       png? ( >=media-libs/libpng-1.2.1 )
+       jpeg? ( >=media-libs/jpeg-6b )
+       fbcon? ( >=media-libs/libpng-1.2.1
+               >=media-libs/jpeg-6b
+               sys-libs/gpm )
+       tiff? ( >=media-libs/tiff-3.5.7 )
+       svga? ( >=media-libs/svgalib-1.4.3
+               >=media-libs/libpng-1.2.1 )
+       X? ( || ( x11-libs/libXext
+               virtual/x11 )
+               >=media-libs/libpng-1.2.1 )
+       directfb? ( dev-libs/DirectFB )
+       sdl? ( >=media-libs/libsdl-1.2.0 )
+       sys-libs/zlib
+       virtual/libc
+       sys-libs/ncurses"
+
+DEPEND="${RDEPEND}
+       sys-devel/automake
+       sys-devel/autoconf
+       sys-devel/gcc
+       dev-util/pkgconfig
+       javascript? ( >=sys-devel/flex-2.5.4a )"
+
+src_unpack (){
+       unpack ${A}; cd "${S}"
+
+       epatch "${FILESDIR}"/configure-LANG.patch #131440
+
+       if use unicode ; then
+               epatch "${WORKDIR}/${PN}-2.1pre22-utf8.diff"
+               cd "${S}/intl" && ./gen-intl && cd .. || die "gen-intl filed"
+       fi
+}
+
+src_compile (){
+       local myconf
+
+       if use X || use fbcon || use directfb || use svga || use livecd; then
+               myconf="${myconf} --enable-graphics"
+       fi
+
+       # Note: --enable-static breaks.
+
+       # Note: ./configure only support 'gpm' features auto-detection, so
+       # we use the autoconf trick
+       ( use gpm || use fbcon || use livecd ) || export ac_cv_lib_gpm_Gpm_Open="no"
+
+       export LANG=C
+
+       if use fbcon || use livecd; then
+               myconf="${myconf} --with-fb"
+       else
+               myconf="${myconf} --without-fb"
+       fi
+
+       # force --with-libjpeg if livecd flag is set
+       if use livecd; then
+               myconf="${myconf} --with-libjpeg"
+       fi
+
+       # hack to allow cross-compilation
+       export CC="$(tc-getCC)"
+
+       econf \
+               $(use_with X x) \
+               $(use_with png libpng) \
+               $(use_with jpeg libjpeg) \
+               $(use_with tiff libtiff) \
+               $(use_with svga svgalib) \
+               $(use_with directfb) \
+               $(use_with ssl) \
+               $(use_with sdl) \
+               $(use_enable javascript) \
+               ${myconf} || die "configure failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       einstall || die
+
+       # Only install links icon if X driver was compiled in ...
+       use X && doicon graphics/links.xpm
+
+       dodoc AUTHORS BUGS ChangeLog NEWS README SITES TODO
+       dohtml doc/links_cal/*
+
+       # Install a compatibility symlink links2:
+       dosym links /usr/bin/links2
+}
+
+
+pkg_postinst() {
+       if use svga ; then
+               einfo "You had the svga USE flag enabled, but for security reasons"
+               einfo "the links2 binary is NOT setuid by default. In order to"
+               einfo "enable links2 to work in SVGA, please change the permissions"
+               einfo "of /usr/bin/links2 to enable suid."
+       fi
+}