dev-python/setuptools: Port to py3.9
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 11:15:07 +0000 (13:15 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 12:18:04 +0000 (14:18 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-46.4.0-r1.ebuild

index fff9aec03927f9cf3075047794f9816710dadf4d..3e7d069b4f865658cf0cb4cfbca62105e3208524 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 PYTHON_REQ_USE="xml(+)"
 
 inherit distutils-r1
@@ -21,12 +21,14 @@ RESTRICT="!test? ( test )"
 BDEPEND="
        app-arch/unzip
        test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pip[${PYTHON_USEDEP}]
-               >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
-               dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
-               dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
-               dev-python/wheel[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       dev-python/mock[${PYTHON_USEDEP}]
+                       dev-python/pip[${PYTHON_USEDEP}]
+                       >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+                       dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+                       dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+                       dev-python/wheel[${PYTHON_USEDEP}]
+               ' python2_7 python3_{6,7,8} pypy3)
                $(python_gen_cond_dep '
                        dev-python/futures[${PYTHON_USEDEP}]
                ' -2)
@@ -63,6 +65,11 @@ python_prepare_all() {
 }
 
 python_test() {
+       if [[ ${EPYTHON} == python3.9 ]]; then
+               einfo "Tests are skipped on py3.9 due to unported deps"
+               return
+       fi
+
        distutils_install_for_testing
        # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
        # It tries to sandbox the test in a tempdir