dev-lang/python: Force-fail stropts.h check for future glibc upgrade
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Mar 2020 17:18:58 +0000 (18:18 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Mar 2020 17:24:03 +0000 (18:24 +0100)
Bug: https://bugs.gentoo.org/699668
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lang/python/python-2.7.17-r1.ebuild
dev-lang/python/python-3.6.10.ebuild
dev-lang/python/python-3.7.7.ebuild
dev-lang/python/python-3.8.2.ebuild
dev-lang/python/python-3.9.0_alpha4.ebuild

index 7f6c843e9f5e87eb101596059c80eb5c13e1649b..544e46b4ffcc27eb3bd6fb380ffe9a692a745478 100644 (file)
@@ -175,6 +175,10 @@ src_configure() {
                # https://bugs.gentoo.org/596798
                # (upstream dropped this flag in 3.2a4 anyway)
                ac_cv_opt_olimit_ok=no
+               # glibc-2.30 removes it; since we can't cleanly force-rebuild
+               # Python on glibc upgrade, remove it proactively to give
+               # a chance for users rebuilding python before glibc
+               ac_cv_header_stropts_h=no
 
                --with-fpectl
                --enable-shared
index 04d1b2520cde73d5c10c27a0eba0e5fa946235ce..72e2472af8f79fe095d72c835445b41a3580d69e 100644 (file)
@@ -133,6 +133,11 @@ src_configure() {
        fi
 
        local myeconfargs=(
+               # glibc-2.30 removes it; since we can't cleanly force-rebuild
+               # Python on glibc upgrade, remove it proactively to give
+               # a chance for users rebuilding python before glibc
+               ac_cv_header_stropts_h=no
+
                --with-fpectl
                --enable-shared
                $(use_enable ipv6)
@@ -150,6 +155,7 @@ src_configure() {
 
        OPT="" econf "${myeconfargs[@]}"
 
+
        if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
                eerror "configure has detected that the sem_open function is broken."
                eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
index 98a67f6b1429f3c3157f105a9c1599f090df2a24..6ad2817ec1e4312121936aa710a64238ea421795 100644 (file)
@@ -128,6 +128,11 @@ src_configure() {
        fi
 
        local myeconfargs=(
+               # glibc-2.30 removes it; since we can't cleanly force-rebuild
+               # Python on glibc upgrade, remove it proactively to give
+               # a chance for users rebuilding python before glibc
+               ac_cv_header_stropts_h=no
+
                --enable-shared
                $(use_enable ipv6)
                --infodir='${prefix}/share/info'
index 0960b3a649781cec10b8b9c109504a82009d573d..831650e0d934fb359c68d9344d9a08f9d719eaf1 100644 (file)
@@ -133,6 +133,11 @@ src_configure() {
        fi
 
        local myeconfargs=(
+               # glibc-2.30 removes it; since we can't cleanly force-rebuild
+               # Python on glibc upgrade, remove it proactively to give
+               # a chance for users rebuilding python before glibc
+               ac_cv_header_stropts_h=no
+
                --enable-shared
                $(use_enable ipv6)
                --infodir='${prefix}/share/info'
index 77a4321ff04492efb342cceb5b7baf2dd7885356..cf3bb88ec5b5bc38eadf3ad00f497415001cfca4 100644 (file)
@@ -149,6 +149,11 @@ src_configure() {
        fi
 
        local myeconfargs=(
+               # glibc-2.30 removes it; since we can't cleanly force-rebuild
+               # Python on glibc upgrade, remove it proactively to give
+               # a chance for users rebuilding python before glibc
+               ac_cv_header_stropts_h=no
+
                --enable-shared
                $(use_enable ipv6)
                --infodir='${prefix}/share/info'