sys-cluster/galera: Remove netcat which is no longer needed in the init
authorBrian Evans <grknight@gentoo.org>
Tue, 18 Aug 2015 20:41:08 +0000 (16:41 -0400)
committerBrian Evans <grknight@gentoo.org>
Tue, 18 Aug 2015 20:41:08 +0000 (16:41 -0400)
Upstream https://github.com/codership/galera/commit/6209a777da487764a728fcb6e9e1f20f82968ee0
removes it

Package-Manager: portage-2.2.20.1

sys-cluster/galera/files/garb.sh
sys-cluster/galera/galera-25.3.10.ebuild

index 63e88dff5cdf1ea05ccafa3e35979e3e02f0603a..da7d55093f5dc5b28083f889bed69fbf4fb17b7f 100644 (file)
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2014 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 depend() {
@@ -22,21 +22,7 @@ start() {
 
        GALERA_PORT="${GALERA_PORT:-4567}"
 
-       for ADDRESS in ${GALERA_NODES} 0; do
-               HOST=$(echo $ADDRESS | cut -d \: -f 1 )
-               PORT=$(echo $ADDRESS | cut -d \: -f 2 )
-               if [ "x${HOST}" = "x${PORT}" ]; then
-                       PORT=${GALERA_PORT}
-               fi
-               PORT=${PORT:-$GALERA_PORT}
-               nc -z ${HOST} ${PORT} > /dev/null &&  break
-       done
-       if [ ${ADDRESS} = "0" ]; then
-               eerror "None of the nodes in GALERA_NODES is accessible"
-               return 1
-       fi
-
-       OPTIONS="-a gcomm://${ADDRESS} -g ${GALERA_GROUP}"
+       OPTIONS="-a gcomm://${GALERA_NODES// /,} -g ${GALERA_GROUP}"
        [ -n "${GALERA_OPTIONS}" ] && OPTIONS="${OPTIONS} -o ${GALERA_OPTIONS}"
         [ -n "${LOG_FILE}" ]       && OPTIONS="${OPTIONS} -l ${LOG_FILE}"
 
index bbaad5afa792f94d263868f49d60fa73a027a2d6..96a2e5c8f38a1e511cfb39fe4db922a651e4b95e 100644 (file)
@@ -28,13 +28,7 @@ DEPEND="${DEPEND}
        >=dev-cpp/asio-1.4.8[ssl?]
        "
 #Run time only
-RDEPEND="${CDEPEND}
-       garbd? ( || (
-               net-analyzer/netcat
-               net-analyzer/netcat6
-               net-analyzer/gnu-netcat
-               net-analyzer/openbsd-netcat
-       ) )"
+RDEPEND="${CDEPEND}"
 
 S="${WORKDIR}/${MY_P}"