net-libs/nghttp3: HTTP/3 library written in C
authorCraig Andrews <candrews@gentoo.org>
Fri, 13 Sep 2019 15:53:43 +0000 (11:53 -0400)
committerCraig Andrews <candrews@gentoo.org>
Fri, 13 Sep 2019 20:38:05 +0000 (16:38 -0400)
Closes: https://bugs.gentoo.org/694304
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
net-libs/nghttp3/Manifest [new file with mode: 0644]
net-libs/nghttp3/metadata.xml [new file with mode: 0644]
net-libs/nghttp3/nghttp3-0_pre20190912.ebuild [new file with mode: 0644]
net-libs/nghttp3/nghttp3-9999.ebuild [new file with mode: 0644]

diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
new file mode 100644 (file)
index 0000000..6280de1
--- /dev/null
@@ -0,0 +1 @@
+DIST nghttp3-0_pre20190912.tar.gz 155172 BLAKE2B fabd472e429222502288b7a4030b4aa51f8a1b609590d63b51ab3f918b8cdb462b766a40911986b3f72f2f1b0debee1f0ebdf8802991bf4fc5d4a6d14297bdcc SHA512 89c7b40843bde9d2c2ab24211794b6ae0e1fa15413e92dcf2238b876552f29bb2f0db724d9a205c2a1c98f25a14ef570c9e53df52fb519230b6f78dcc04d2117
diff --git a/net-libs/nghttp3/metadata.xml b/net-libs/nghttp3/metadata.xml
new file mode 100644 (file)
index 0000000..d47d5fa
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>candrews@integralblue.com</email>
+               <name>Craig Andrews</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">ngtcp2/ngtcp2</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
new file mode 100644 (file)
index 0000000..6489dde
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+       inherit autotools git-r3
+else
+       GIT_COMMIT="51379a041174ad953dc6ad437712f3b279f81919"
+       SRC_URI="https://github.com/ngtcp2/nghttp3/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DENABLE_LIB_ONLY=ON
+               -DENABLE_EXAMPLES=OFF
+               -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+       )
+       cmake-utils_src_configure
+}
+
+multilib_src_test() {
+       cmake-utils_src_make check
+}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
new file mode 100644 (file)
index 0000000..62a48b6
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+       inherit autotools git-r3
+else
+       SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DENABLE_LIB_ONLY=ON
+               -DENABLE_EXAMPLES=OFF
+               -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+       )
+       cmake-utils_src_configure
+}
+
+multilib_src_test() {
+       cmake-utils_src_make check
+}