dev-haskell/unexceptionalio: new package, a depend of dev-haskell/errors-2.1.3
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 15 Feb 2017 23:19:53 +0000 (23:19 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:52 +0000 (10:21 +0000)
IO without any non-error, synchronous exceptions

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/unexceptionalio/Manifest [new file with mode: 0644]
dev-haskell/unexceptionalio/metadata.xml [new file with mode: 0644]
dev-haskell/unexceptionalio/unexceptionalio-0.3.0.ebuild [new file with mode: 0644]

diff --git a/dev-haskell/unexceptionalio/Manifest b/dev-haskell/unexceptionalio/Manifest
new file mode 100644 (file)
index 0000000..4918e5d
--- /dev/null
@@ -0,0 +1 @@
+DIST unexceptionalio-0.3.0.tar.gz 2335 SHA256 927e2be6bb9ced73c1c17d79c981cadef4039d9ee45d2d3d6b4c133ff93ff0b8 SHA512 be6479cfdb39707473e07639b3a35c4e178571ec2b45a356e278c9bb20710775fe26c086239aa65c2d5f201730df223b5ca3e42ea61e1ffb9a285f384e62f4b6 WHIRLPOOL 2f63cd0e673243f0cbe13b756969032b513a288d89c06ea4bda00174d452971878717397da1de270078ee11cf351263be354a2ef3d80c625442524f687496f16
diff --git a/dev-haskell/unexceptionalio/metadata.xml b/dev-haskell/unexceptionalio/metadata.xml
new file mode 100644 (file)
index 0000000..86c987b
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               When you&#39;ve caught all the exceptions that can be handled safely,
+               this is what you&#39;re left with.
+               
+               It is intended that you use qualified imports with this library.
+               
+               &gt; import UnexceptionalIO (UIO)
+               &gt; import qualified UnexceptionalIO as UIO
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/unexceptionalio/unexceptionalio-0.3.0.ebuild b/dev-haskell/unexceptionalio/unexceptionalio-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..44f256f
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="IO without any non-error, synchronous exceptions"
+HOMEPAGE="https://github.com/singpolyma/unexceptionalio"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.8
+"