www-apps/wordpress: bump 5.3.2
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 19 Dec 2019 09:08:34 +0000 (10:08 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 19 Dec 2019 09:08:34 +0000 (10:08 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
www-apps/wordpress/Manifest
www-apps/wordpress/wordpress-5.3.2.ebuild [new file with mode: 0644]

index 150f23d8b3a3441eec02ac68340c39e8ddac5a81..3dc199ef6e70a96b2d6e9d3d5ab01b73e745542a 100644 (file)
@@ -1 +1,2 @@
 DIST wordpress-5.3.1.tar.gz 12388850 BLAKE2B bc1158f5573fb601361eec27dfde9239b2387b6faaba307e33b13f93c08b81768ebed0f6a4a59f503f5c959cc14c689ecb528f79cf2ae4b31c92f4e7b6104d88 SHA512 97a3297305ae23bf0d1d295a3df1516dcafc1486a63974357bfc46963cecf0bfd982edc68efd60a0ceb4014fdcdde9fc71e7257a5f5d011922d8dfce280e1a9a
+DIST wordpress-5.3.2.tar.gz 12389281 BLAKE2B 54222e9bfd5e5ee874845bab5a7e2a9d0677bbc97c70bd3b72bf2109683933116cbce2b5323f51236df68137be6987f9937b41a004feaaa5da13007b114135d6 SHA512 d766d485d9a6a6efb2b92ffaec2ba1f773e55a6e018759bb6b196469b73db2857c34a3dfca1ac406e2b7066072a35c070c99f24b285a47b050e3d21317785198
diff --git a/www-apps/wordpress/wordpress-5.3.2.ebuild b/www-apps/wordpress/wordpress-5.3.2.ebuild
new file mode 100644 (file)
index 0000000..5a8f16d
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+       || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+       webapp_src_preinst
+
+       dodoc readme.html
+       rm readme.html license.txt || die
+
+       if use !akismet ; then
+               rm -R wp-content/plugins/akismet/ || die
+       fi
+       if use !examples ; then
+               rm wp-content/plugins/hello.php || die
+       fi
+       if use !themes ; then
+               rm -R wp-content/themes/*/ || die
+       fi
+
+       [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+       webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+       webapp_serverowned "${MY_HTDOCSDIR}"
+       # allows plugins update if allowed within WP
+       webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+       webapp_configfile  "${MY_HTDOCSDIR}"/wp-config.php
+
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+       webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+       webapp_src_install
+}