dev-python/python-fastcgi: Use append-cflags
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:46:13 +0000 (18:46 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:53:46 +0000 (18:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/python-fastcgi/python-fastcgi-1.1-r1.ebuild

index 77734049006cd1767711c7c1ad7945a02033c210..147c649b4047bb468dac44238158c83bc2a906b1 100644 (file)
@@ -3,9 +3,10 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
 
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
 
 DESCRIPTION="Interface to OpenMarket's FastCGI C Library/SDK"
 HOMEPAGE="https://pypi.python.org/pypi/python-fastcgi"
@@ -20,10 +21,13 @@ RDEPEND=">=dev-libs/fcgi-2.4.0-r2"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]"
 
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
 PATCHES=( "${FILESDIR}/${P}-setup.patch" )
 
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       append-cflags -fno-strict-aliasing
+}
+
 python_install_all() {
        use examples && local EXAMPLES=( example/. )
        distutils-r1_python_install_all