app-arch/file-roller: Fix compiling against GCC 10
authorDavid Seifert <soap@gentoo.org>
Wed, 19 Feb 2020 12:22:32 +0000 (13:22 +0100)
committerDavid Seifert <soap@gentoo.org>
Wed, 19 Feb 2020 12:22:32 +0000 (13:22 +0100)
Bug: https://bugs.gentoo.org/706728
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
app-arch/file-roller/file-roller-3.32.4.ebuild
app-arch/file-roller/files/file-roller-3.32.4-fno-common.patch [new file with mode: 0644]

index e414eeeaab8146a502569f3db84927bc695ec9e3..d57a9d8778e5de382d999db66e3b6c5987d518d9 100644 (file)
@@ -56,6 +56,11 @@ rpm     - app-arch/rpm
 unstuff - app-arch/stuffit
 zoo     - app-arch/zoo"
 
+PATCHES=(
+       # https://gitlab.gnome.org/GNOME/file-roller/merge_requests/31
+       "${FILESDIR}"/${PN}-3.32.4-fno-common.patch
+)
+
 src_prepare() {
        # File providing Gentoo package names for various archivers
        cp -v "${FILESDIR}"/3.32-packages.match data/packages.match || die
diff --git a/app-arch/file-roller/files/file-roller-3.32.4-fno-common.patch b/app-arch/file-roller/files/file-roller-3.32.4-fno-common.patch
new file mode 100644 (file)
index 0000000..9239810
--- /dev/null
@@ -0,0 +1,27 @@
+From 55fa0fb287e7fb7cee336cac0a6c1a94e505dc84 Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Wed, 19 Feb 2020 13:18:18 +0100
+Subject: [PATCH] Fix compiling with GCC 10
+
+* GCC 10 defaults to `-fno-common`.
+
+Bug: https://bugs.gentoo.org/706728
+---
+ src/fr-application.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/fr-application.c b/src/fr-application.c
+index c148c4f9..00ebe552 100644
+--- a/src/fr-application.c
++++ b/src/fr-application.c
+@@ -42,7 +42,6 @@
+ #define SERVICE_TIMEOUT 10
+-gint                ForceDirectoryCreation;
+ static char       **remaining_args;
+ static char        *arg_add_to = NULL;
+ static int          arg_add = FALSE;
+-- 
+2.25.1
+