app-shells/zsh: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 17 Feb 2020 08:13:15 +0000 (09:13 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 17 Feb 2020 08:13:15 +0000 (09:13 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-shells/zsh/Manifest
app-shells/zsh/zsh-5.6.2.ebuild [deleted file]
app-shells/zsh/zsh-5.7.1.ebuild [deleted file]

index 0441d140d044c0153a4c8900570ffacf2b1fd15b..1a144b9f3a00dca1f388a0c861b6483e13da7d3f 100644 (file)
@@ -1,5 +1,3 @@
-DIST zsh-5.6.2-doc.tar.xz 3198932 BLAKE2B 7e701bb12e0114b7d9847caad1146fa3d538f8f6d859a765037660fb18341f1c79002811a42ec795e41eb2bbe899e12d4bcd055ea5c66e7b73bd488bdf8bbb55 SHA512 5102314e2857b032c6e6b4b715c261970b2f0c28663aff99fb87f7bb6c3971f88f8e8892ed349793570beae3fb68ff7923c82e99a3c1bb485e4639f01caaad4a
-DIST zsh-5.6.2.tar.xz 3077368 BLAKE2B 8c6ce22436f9f51eff809c779efad02f4a0730b4431630ab305abc9f1ef722698f7c565d0aa421b0d94c21f2c830f9d529709fd62a4205be1a20acf0f94a845a SHA512 f0a49e41b55eb478692ab5471d7c9828956b7e96bc82944202b0ef1c49a889b21a0e7682aa5f59fd0054ebfd866c2244c8a622e7aa46c13038af5c226c48a3a2
 DIST zsh-5.7.1-doc.tar.xz 3062112 BLAKE2B cb67aada97d79b4b5b1116fb0737294785a2a510c2f4396cf77b671b62631e778ee9d57a32dcd257e079a9e4c35acaeeb68c0ec951b6ae8d8d8b647c05ef365c SHA512 e51bc8eb408bcb20bf8a4f0b8588f7803fdd433445efa282f598a3bec4575cba7feaad117cd2d5077f51150bf0ba41a673ffb925ade33c435db498f1d791cc8c
 DIST zsh-5.7.1.tar.xz 3126308 BLAKE2B 4f1aa2d5aea0341ba7839cf05687020889b5ca6879654a376ce838986211af4bddb7ab521a8a35cc06701f730a75a9778c633726b447f31845f5c140ec1e8d80 SHA512 a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0
 DIST zsh-5.8-doc.tar.xz 3088696 BLAKE2B f738bf15b137e84df91fff8500b6c309884d8a1777e3158807f6028a411ae3f345e6ccba49bdff04c6607c4eb06fc2913313e84e1f78be0a0f92d23e46ba87db SHA512 38cc549818eb9c6952051b714dd2008d99605aba4ca4f614e62b033c9b067dd2031fff766ac5c1efe5bb52eae32bd482dea5df2b2d46decb7ecdb458f3da9d52
diff --git a/app-shells/zsh/zsh-5.6.2.ebuild b/app-shells/zsh/zsh-5.6.2.ebuild
deleted file mode 100644 (file)
index aa8fb58..0000000
+++ /dev/null
@@ -1,211 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic prefix
-
-if [[ ${PV} == 9999* ]] ; then
-       inherit git-r3 autotools
-       EGIT_REPO_URI="https://git.code.sf.net/p/zsh/code"
-else
-       KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-       SRC_URI="https://www.zsh.org/pub/${P}.tar.xz
-               https://www.zsh.org/pub/old/${P}.tar.xz
-               doc? ( https://www.zsh.org/pub/${P}-doc.tar.xz )"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="https://www.zsh.org/"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
-       >=sys-libs/ncurses-5.1:0=
-       static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
-       caps? ( sys-libs/libcap )
-       pcre? (
-               >=dev-libs/libpcre-3.9
-               static? ( >=dev-libs/libpcre-3.9[static-libs] )
-       )
-       gdbm? ( sys-libs/gdbm:= )
-       !<sys-apps/baselayout-2.4.1
-"
-DEPEND="sys-apps/groff
-       ${RDEPEND}"
-PDEPEND="
-       examples? ( app-doc/zsh-lovers )
-"
-if [[ ${PV} == 9999* ]] ; then
-       DEPEND+=" app-text/yodl
-               doc? (
-                       sys-apps/texinfo
-                       app-text/texi2html
-                       virtual/latex-base
-               )"
-fi
-
-src_prepare() {
-       if [[ ${PV} != 9999* ]]; then
-               # fix zshall problem with soelim
-               ln -s Doc man1 || die
-               mv Doc/zshall.1 Doc/zshall.1.soelim || die
-               soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
-
-               # add openrc specific options for init.d completion
-               eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
-       fi
-
-       eapply_user
-
-       if [[ ${PV} == 9999* ]] ; then
-               sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
-               eautoreconf
-       fi
-}
-
-src_configure() {
-       local myconf=(
-               --bindir="${EPREFIX}"/bin
-               --libdir="${EPREFIX}"/usr/$(get_libdir)
-               --enable-etcdir="${EPREFIX}"/etc/zsh
-               --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help
-               --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions
-               --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
-               --enable-function-subdirs
-               --with-tcsetpgrp
-               $(use_enable maildir maildir-support)
-               $(use_enable pcre)
-               $(use_enable caps cap)
-               $(use_enable unicode multibyte)
-               $(use_enable gdbm)
-       )
-
-       if use static ; then
-               myconf+=( --disable-dynamic )
-               append-ldflags -static
-       fi
-       if use debug ; then
-               myconf+=(
-                       --enable-zsh-debug
-                       --enable-zsh-mem-debug
-                       --enable-zsh-mem-warning
-                       --enable-zsh-secure-free
-                       --enable-zsh-hash-debug
-               )
-       fi
-
-       if [[ ${CHOST} == *-darwin* ]]; then
-               myconf+=( --enable-libs=-liconv )
-               append-ldflags -Wl,-x
-       fi
-
-       econf "${myconf[@]}"
-
-       if use static ; then
-               # compile all modules statically, see Bug #27392
-               # removed cap and curses because linking failes
-               sed -e "s,link=no,link=static,g" \
-                       -e "/^name=zsh\/cap/s,link=static,link=no," \
-                       -e "/^name=zsh\/curses/s,link=static,link=no," \
-                       -i "${S}"/config.modules || die
-               if ! use gdbm ; then
-                       sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
-                               "${S}"/config.modules || die
-               fi
-       fi
-}
-
-src_compile() {
-       default
-
-       if [[ ${PV} == 9999* ]] && use doc ; then
-               emake -C Doc everything
-       fi
-}
-
-src_test() {
-       addpredict /dev/ptmx
-       local i
-       for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
-               rm "${S}"/Test/${i} || die
-       done
-       emake check
-}
-
-src_install() {
-       emake DESTDIR="${D}" install $(usex doc "install.info" "")
-
-       insinto /etc/zsh
-       export PREFIX_QUOTE_CHAR='"' PREFIX_EXTRA_REGEX="/EUID/s,0,${EUID},"
-       newins "$(prefixify_ro "${FILESDIR}"/zprofile-4)" zprofile
-
-       keepdir /usr/share/zsh/site-functions
-       insinto /usr/share/zsh/${PV%_*}/functions/Prompts
-       newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
-       local i
-
-       # install miscellaneous scripts (bug #54520)
-       sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
-               -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
-               -i {Util,Misc}/* || die
-       for i in Util Misc ; do
-               insinto /usr/share/zsh/${PV%_*}/${i}
-               doins ${i}/*
-       done
-
-       # install header files (bug #538684)
-       insinto /usr/include/zsh
-       doins config.h Src/*.epro
-       for i in Src/{zsh.mdh,*.h} ; do
-               sed -e 's@\.\./config\.h@config.h@' \
-                       -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
-                       -i "${i}"
-               doins "${i}"
-       done
-
-       dodoc ChangeLog* META-FAQ NEWS README config.modules
-
-       if use doc ; then
-               pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
-               dodoc Doc/zsh.{dvi,pdf}
-               docinto html
-               dodoc Doc/*.html
-               popd >/dev/null
-       fi
-
-       docinto StartupFiles
-       dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
-       if [[ -z ${REPLACING_VERSIONS} ]] ; then
-               echo
-               elog "If you want to enable Portage completions and Gentoo prompt,"
-               elog "emerge app-shells/gentoo-zsh-completions and add"
-               elog "  autoload -U compinit promptinit"
-               elog "  compinit"
-               elog "  promptinit; prompt gentoo"
-               elog "to your ~/.zshrc"
-               echo
-               elog "Also, if you want to enable cache for the completions, add"
-               elog "  zstyle ':completion::complete:*' use-cache 1"
-               elog "to your ~/.zshrc"
-               echo
-               elog "Note that a system zprofile startup file is installed. This will override"
-               elog "PATH and possibly other variables that a user may set in ~/.zshenv."
-               elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
-               elog "or other user startup files that are sourced after the system zprofile."
-               echo
-               elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
-               elog "one method is to use a separate path-setting file that is conditionally sourced"
-               elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
-               elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
-               echo
-               elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
-               echo
-       fi
-}
diff --git a/app-shells/zsh/zsh-5.7.1.ebuild b/app-shells/zsh/zsh-5.7.1.ebuild
deleted file mode 100644 (file)
index c9003da..0000000
+++ /dev/null
@@ -1,216 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic prefix
-
-if [[ ${PV} == 9999* ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://git.code.sf.net/p/zsh/code"
-else
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-       SRC_URI="https://www.zsh.org/pub/${P}.tar.xz
-               https://www.zsh.org/pub/old/${P}.tar.xz
-               mirror://sourceforge/${PN}/${P}.tar.xz
-               doc? (
-                       https://www.zsh.org/pub/${P}-doc.tar.xz
-                       mirror://sourceforge/${PN}/${P}-doc.tar.xz
-               )"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="https://www.zsh.org/"
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-IUSE="caps debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
-       >=sys-libs/ncurses-5.1:0=
-       static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
-       caps? ( sys-libs/libcap )
-       pcre? (
-               >=dev-libs/libpcre-3.9
-               static? ( >=dev-libs/libpcre-3.9[static-libs] )
-       )
-       gdbm? ( sys-libs/gdbm:= )
-       !<sys-apps/baselayout-2.4.1
-"
-DEPEND="sys-apps/groff
-       ${RDEPEND}"
-PDEPEND="
-       examples? ( app-doc/zsh-lovers )
-"
-if [[ ${PV} == 9999* ]] ; then
-       DEPEND+=" app-text/yodl
-               doc? (
-                       sys-apps/texinfo
-                       app-text/texi2html
-                       virtual/latex-base
-               )"
-fi
-
-src_prepare() {
-       if [[ ${PV} != 9999* ]]; then
-               # fix zshall problem with soelim
-               ln -s Doc man1 || die
-               mv Doc/zshall.1 Doc/zshall.1.soelim || die
-               soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
-
-               # add openrc specific options for init.d completion
-               eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
-       fi
-
-       default
-
-       hprefixify configure.ac
-       if [[ ${PV} == 9999* ]] ; then
-               sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
-       fi
-       eautoreconf
-}
-
-src_configure() {
-       local myconf=(
-               --bindir="${EPREFIX}"/bin
-               --libdir="${EPREFIX}"/usr/$(get_libdir)
-               --enable-etcdir="${EPREFIX}"/etc/zsh
-               --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help
-               --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions
-               --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions
-               --enable-function-subdirs
-               --with-tcsetpgrp
-               $(use_enable maildir maildir-support)
-               $(use_enable pcre)
-               $(use_enable caps cap)
-               $(use_enable unicode multibyte)
-               $(use_enable gdbm)
-       )
-
-       if use static ; then
-               myconf+=( --disable-dynamic )
-               append-ldflags -static
-       fi
-       if use debug ; then
-               myconf+=(
-                       --enable-zsh-debug
-                       --enable-zsh-mem-debug
-                       --enable-zsh-mem-warning
-                       --enable-zsh-secure-free
-                       --enable-zsh-hash-debug
-               )
-       fi
-
-       if [[ ${CHOST} == *-darwin* ]]; then
-               myconf+=( --enable-libs=-liconv )
-               append-ldflags -Wl,-x
-       fi
-
-       econf "${myconf[@]}"
-
-       if use static ; then
-               # compile all modules statically, see Bug #27392
-               # removed cap and curses because linking failes
-               sed -e "s,link=no,link=static,g" \
-                       -e "/^name=zsh\/cap/s,link=static,link=no," \
-                       -e "/^name=zsh\/curses/s,link=static,link=no," \
-                       -i "${S}"/config.modules || die
-               if ! use gdbm ; then
-                       sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
-                               "${S}"/config.modules || die
-               fi
-       fi
-}
-
-src_compile() {
-       default
-
-       if [[ ${PV} == 9999* ]] && use doc ; then
-               emake -C Doc everything
-       fi
-}
-
-src_test() {
-       addpredict /dev/ptmx
-       local i
-       for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
-               rm "${S}"/Test/${i} || die
-       done
-       emake check
-}
-
-src_install() {
-       emake DESTDIR="${D}" install $(usex doc "install.info" "")
-
-       insinto /etc/zsh
-       export PREFIX_QUOTE_CHAR='"' PREFIX_EXTRA_REGEX="/EUID/s,0,${EUID},"
-       newins "$(prefixify_ro "${FILESDIR}"/zprofile-4)" zprofile
-
-       keepdir /usr/share/zsh/site-functions
-       insinto /usr/share/zsh/${PV%_*}/functions/Prompts
-       newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
-       local i
-
-       # install miscellaneous scripts (bug #54520)
-       sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
-               -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
-               -i {Util,Misc}/* || die
-       for i in Util Misc ; do
-               insinto /usr/share/zsh/${PV%_*}/${i}
-               doins ${i}/*
-       done
-
-       # install header files (bug #538684)
-       insinto /usr/include/zsh
-       doins config.h Src/*.epro
-       for i in Src/{zsh.mdh,*.h} ; do
-               sed -e 's@\.\./config\.h@config.h@' \
-                       -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
-                       -i "${i}"
-               doins "${i}"
-       done
-
-       dodoc ChangeLog* META-FAQ NEWS README config.modules
-
-       if use doc ; then
-               pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
-               dodoc Doc/zsh.{dvi,pdf}
-               docinto html
-               dodoc Doc/*.html
-               popd >/dev/null
-       fi
-
-       docinto StartupFiles
-       dodoc StartupFiles/z*
-}
-
-pkg_postinst() {
-       if [[ -z ${REPLACING_VERSIONS} ]] ; then
-               echo
-               elog "If you want to enable Portage completions and Gentoo prompt,"
-               elog "emerge app-shells/gentoo-zsh-completions and add"
-               elog "  autoload -U compinit promptinit"
-               elog "  compinit"
-               elog "  promptinit; prompt gentoo"
-               elog "to your ~/.zshrc"
-               echo
-               elog "Also, if you want to enable cache for the completions, add"
-               elog "  zstyle ':completion::complete:*' use-cache 1"
-               elog "to your ~/.zshrc"
-               echo
-               elog "Note that a system zprofile startup file is installed. This will override"
-               elog "PATH and possibly other variables that a user may set in ~/.zshenv."
-               elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
-               elog "or other user startup files that are sourced after the system zprofile."
-               echo
-               elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
-               elog "one method is to use a separate path-setting file that is conditionally sourced"
-               elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
-               elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
-               echo
-               elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
-               echo
-       fi
-}