mail-client/alot: version bump 0.9
authorGuillaume Seren <guillaumeseren@gmail.com>
Sun, 23 Feb 2020 20:31:09 +0000 (21:31 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 5 Mar 2020 11:58:30 +0000 (13:58 +0200)
Closes: https://bugs.gentoo.org/710610
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
mail-client/alot/Manifest
mail-client/alot/alot-0.9.ebuild [new file with mode: 0644]
mail-client/alot/files/0.9-0001-remove-non-working-test.patch [new file with mode: 0644]
mail-client/alot/files/0.9-0002-update-reference-to-envelope-body.patch [new file with mode: 0644]

index 45b2450ac3958024f970b5ab2d3232dce21716d6..a09eea0399982d753713d25472660c412d5cd637 100644 (file)
@@ -1 +1,2 @@
 DIST alot-0.8.1.tar.gz 220342 BLAKE2B 019f41f1f1fe73aa17a309a73b12883cbbae6a232d912d0e328b3862fc4e8e49ea6a3d0b6e2921ecb4d6ee8a58a9f6826facd7ff4cd6fafc17f6f5fe0195dd2c SHA512 bca4a01636594f0e71c6ea260d74cf26e74dfd7aca1ea7801714b4aaf9602ae7737769e77e3af0363ed2701df1494e0f87ce85b58c47a6380ad1a9098f8501d4
+DIST alot-0.9.tar.gz 224932 BLAKE2B 6063b9974ec54b51521ec52db41519bd9f16cc8da611b1a2da7de3f7581a924962a79ca8193ad0bb36633141182c047f32c5ab58132c78e1ec036e4da684181c SHA512 e630ea18702c570630deb10347c52e03aecb297bc1f76ce60318eeb8725274b12eb408cbceb69c8035b1ec9ea778f19a035f48070606bc6540b68a4bc5591860
diff --git a/mail-client/alot/alot-0.9.ebuild b/mail-client/alot/alot-0.9.ebuild
new file mode 100644 (file)
index 0000000..248997e
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="https://github.com/pazz/alot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       app-crypt/gpgme[python,${PYTHON_USEDEP}]
+       dev-python/configobj[${PYTHON_USEDEP}]
+       dev-python/python-magic[${PYTHON_USEDEP}]
+       dev-python/urwid[${PYTHON_USEDEP}]
+       dev-python/urwidtrees[${PYTHON_USEDEP}]
+       >=dev-python/twisted-18.4[${PYTHON_USEDEP}]
+       net-mail/mailbase
+       net-mail/notmuch[crypt,python]
+       "
+DEPEND="
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+       "
+
+PATCHES=(
+       "${FILESDIR}/${PV}-0001-remove-non-working-test.patch"
+       "${FILESDIR}/${PV}-0002-update-reference-to-envelope-body.patch"
+       )
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+       emake -C docs man
+       use doc && emake -C docs html
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/build/html/. )
+       doman docs/build/man/*
+       distutils-r1_python_install_all
+
+       insinto /usr/share/alot
+       doins -r extra
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               elog ""
+               elog "If you are new to Alot you may want to take a look at"
+               elog "the user manual:"
+               elog "   https://alot.readthedocs.io/en/latest/"
+               elog ""
+       fi
+}
diff --git a/mail-client/alot/files/0.9-0001-remove-non-working-test.patch b/mail-client/alot/files/0.9-0001-remove-non-working-test.patch
new file mode 100644 (file)
index 0000000..505f112
--- /dev/null
@@ -0,0 +1,31 @@
+From d534d65e1d4855565124906319c54b179dae20bd Mon Sep 17 00:00:00 2001
+From: Guillaume Seren <guillaumeseren@gmail.com>
+Date: Fri, 3 May 2019 18:17:05 +0200
+Subject: [PATCH] Remove non working test
+
+Some test are not working + fix for master
+---
+ tests/commands/test_global.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/tests/commands/test_global.py b/tests/commands/test_global.py
+index 775a822c..ca79443f 100644
+--- a/tests/commands/test_global.py
++++ b/tests/commands/test_global.py
+@@ -121,13 +121,6 @@ class TestExternalCommand(unittest.TestCase):
+         await cmd.apply(ui)
+         ui.notify.assert_not_called()
+-    @utilities.async_test
+-    async def test_no_spawn_no_stdin_attached(self):
+-        ui = utilities.make_ui()
+-        cmd = g_commands.ExternalCommand('test -t 0', refocus=False)
+-        await cmd.apply(ui)
+-        ui.notify.assert_not_called()
+-
+     @utilities.async_test
+     async def test_no_spawn_stdin_attached(self):
+         ui = utilities.make_ui()
+-- 
+2.24.1
+
diff --git a/mail-client/alot/files/0.9-0002-update-reference-to-envelope-body.patch b/mail-client/alot/files/0.9-0002-update-reference-to-envelope-body.patch
new file mode 100644 (file)
index 0000000..8010b50
--- /dev/null
@@ -0,0 +1,28 @@
+From 67a06f5b9afa132a187956d5f28b0470b84a0235 Mon Sep 17 00:00:00 2001
+From: Patrick Totzke <patricktotzke@gmail.com>
+Date: Sun, 16 Feb 2020 10:24:59 +0000
+Subject: [PATCH] Update reference to envelope.body
+
+which now should be body_txt as of e067ea2037c10224645f0cb7ab2e020772e612ac
+
+fixes #1468
+---
+ alot/commands/globals.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/alot/commands/globals.py b/alot/commands/globals.py
+index f9dc5812..aa1fd436 100644
+--- a/alot/commands/globals.py
++++ b/alot/commands/globals.py
+@@ -869,7 +869,7 @@ class ComposeCommand(Command):
+                     mimetype = helper.guess_mimetype(sigcontent)
+                     if mimetype.startswith('text'):
+                         sigcontent = helper.try_decode(sigcontent)
+-                        self.envelope.body += '\n' + sigcontent
++                        self.envelope.body_txt += '\n' + sigcontent
+             else:
+                 ui.notify('could not locate signature: %s' % sig,
+                           priority='error')
+-- 
+2.24.1
+