media-gfx/fotowall: fix build with Qt 5.11
authorMichael Palimaka <kensington@gentoo.org>
Sat, 6 Oct 2018 15:01:07 +0000 (01:01 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 6 Oct 2018 15:02:00 +0000 (01:02 +1000)
Closes: https://bugs.gentoo.org/661596
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch [new file with mode: 0644]
media-gfx/fotowall/fotowall-1.0.ebuild

diff --git a/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch b/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch
new file mode 100644 (file)
index 0000000..db61977
--- /dev/null
@@ -0,0 +1,28 @@
+Fix build with Qt 5.11.
+
+Bug: https://bugs.gentoo.org/661596
+
+--- a/App/tmp/CanvasAppliance.h
++++ b/App/CanvasAppliance.h
+@@ -17,6 +17,9 @@
+ #include "Shared/PlugGui/AbstractAppliance.h"
+ #include "ui_CanvasAppliance.h"
++
++#include <QActionGroup>
++
+ class QMenu;
+ class AbstractContent;
+ class Canvas;
+
+--- a/3rdparty/likebackfrontend/LikeBackDialog.cpp
++++ b/3rdparty/likebackfrontend/LikeBackDialog.cpp
+@@ -37,6 +37,7 @@
+ #include "LikeBackDialog.h"
+ #include <QApplication>
++#include <QButtonGroup>
+ #include <QLocale>
+ #include <QMessageBox>
+ #include <QNetworkAccessManager>
+
index c4b9af4bfab4d609e69f362f7462fa263f5a9684..660c5442ca6f9ecc080e55bf44dfa31ec2b7bb70 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -31,6 +31,8 @@ DEPEND="${RDEPEND}
 src_prepare() {
        default
 
+       eapply "${FILESDIR}/${P}-qt-5.11.patch"
+
        sed -i -e "s|linux/videodev.h|libv4l1-videodev.h|" \
                3rdparty/videocapture/VideoDevice.h || die