dev-python/egenix-mx-base: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Mon, 9 Mar 2020 09:32:35 +0000 (10:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 9 Mar 2020 09:32:35 +0000 (10:32 +0100)
Closes: https://bugs.gentoo.org/708332
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/egenix-mx-base/Manifest [deleted file]
dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild [deleted file]
dev-python/egenix-mx-base/egenix-mx-base-3.2.8.ebuild [deleted file]
dev-python/egenix-mx-base/egenix-mx-base-3.2.9.ebuild [deleted file]
dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch [deleted file]
dev-python/egenix-mx-base/metadata.xml [deleted file]
profiles/package.mask

diff --git a/dev-python/egenix-mx-base/Manifest b/dev-python/egenix-mx-base/Manifest
deleted file mode 100644 (file)
index bb1956c..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST egenix-mx-base-3.2.5.tar.gz 4575752 BLAKE2B f113aeac32f9d648d4f90124397e03f6cdd173a23a64b8572cbbf4c01a78c66f6853944616ca682e88d605a248ec9de6144f4430559e8d99c65710360df8107e SHA512 707d4cb96de04f967c1a37d156f41d9570b580088132f96533b7b4319c1fc0492a29b01ce1dba9527d7fc7cada99da8767a55c0994c285af81af82fd0f370a42
-DIST egenix-mx-base-3.2.8.tar.gz 4597088 BLAKE2B 8f74031d5793cb04a930bb2192f7173e1c4c0fe32a3c1915d1feaf5db80711f2cd7344614066a60ef4d87ee2b3270197e706052bafdb7c6ea6f2a0176f14ecf9 SHA512 26a8d53c2a8ccfe088ac201d0b50d9becc402220746dae2f4fe67b55a1c0cff29b6b7f635f689752c4d444bb05b5edc30972354301830ae24e13b845596dcff9
-DIST egenix-mx-base-3.2.9.tar.gz 4611603 BLAKE2B b27afe2c06458d94b560fdfc1559a5afa68aa904d0947ac972ed08a3194eb7a99c7a1f7b10f359fd46407f0ce02b7edd0833e05ce2faffd62ca924cb7f766981 SHA512 ff3b6ba90e9729004e7b18511a69529698b7d6089f08b686a0930d8f065323933e9fb97f2ed7a5b24c4bca0ddad1983773144b5dd9ee401859a2ffbfcfc79025
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
deleted file mode 100644 (file)
index 038d74f..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="eGenix utils for Python"
-HOMEPAGE="https://www.egenix.com/products/python/mxBase https://pypi.org/project/egenix-mx-base/"
-SRC_URI="https://downloads.egenix.com/python/${P}.tar.gz"
-
-LICENSE="eGenixPublic-1.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-# distutils.command.config writes to CWD, bug #450516
-# mxSetup.py is broken with --build-lib
-#DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       # Don't install documentation in site-packages directories.
-       sed -e "/\.pdf/d" -i egenix_mx_base.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       local t
-
-       while IFS= read -r -d '' t
-       do
-               "${PYTHON}" "${t}" || die "${t} failed with ${EPYTHON}"
-       done < <(find -name test.py -print0)
-}
-
-python_install() {
-       local f dest=${D}$(python_get_includedir)/mx
-
-       distutils-r1_python_install \
-               build --build-platlib "${BUILD_DIR}"/lib
-
-       mkdir -p "${dest}" || die
-       while IFS= read -r -d '' f
-       do
-               mv -f "${f}" "${dest}" || die
-       done < <(find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
-}
-
-python_install_all() {
-       local f
-
-       distutils-r1_python_install_all
-
-       dohtml -a html -r mx
-       while IFS= read -r -d '' f
-       do
-               dodoc "${f}"
-       done < <(find -name '*.pdf' -print0)
-}
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.8.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.8.ebuild
deleted file mode 100644 (file)
index 364512c..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="eGenix utils for Python"
-HOMEPAGE="https://www.egenix.com/products/python/mxBase https://pypi.org/project/egenix-mx-base/"
-SRC_URI="https://downloads.egenix.com/python/${P}.tar.gz"
-
-LICENSE="eGenixPublic-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-# Correct broken tests
-PATCHES=( "${FILESDIR}"/${PN}-3.2.6-tests.patch )
-
-python_prepare_all() {
-       # Don't install documentation in site-packages directories.
-       sed -e "/\.pdf/d" -i egenix_mx_base.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       if ! python_is_python3; then
-               local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-       fi
-       distutils-r1_python_compile
-}
-
-python_test() {
-       local t
-
-       while IFS= read -r -d '' t
-       do
-               "${PYTHON}" "${t}" || die "${t} failed with ${EPYTHON}"
-       done < <(find -name test.py -print0)
-}
-
-python_install() {
-       local f dest=${D}$(python_get_includedir)/mx
-
-       distutils-r1_python_install \
-               build --build-platlib "${BUILD_DIR}"/lib
-
-       mkdir -p "${dest}" || die
-       while IFS= read -r -d '' f
-       do
-               mv -f "${f}" "${dest}" || die
-       done < <(find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
-}
-
-python_install_all() {
-       local f
-
-       distutils-r1_python_install_all
-
-       dohtml -a html -r mx
-       while IFS= read -r -d '' f
-       do
-               dodoc "${f}"
-       done < <(find -name '*.pdf' -print0)
-}
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.9.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.9.ebuild
deleted file mode 100644 (file)
index ab3aba6..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="eGenix utils for Python"
-HOMEPAGE="https://www.egenix.com/products/python/mxBase https://pypi.org/project/egenix-mx-base/"
-SRC_URI="https://downloads.egenix.com/python/${P}.tar.gz"
-
-LICENSE="eGenixPublic-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-# Correct broken tests
-PATCHES=( "${FILESDIR}"/${PN}-3.2.6-tests.patch )
-
-python_prepare_all() {
-       # Don't install documentation in site-packages directories.
-       sed -e "/\.pdf/d" -i egenix_mx_base.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       if ! python_is_python3; then
-               local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-       fi
-       distutils-r1_python_compile
-}
-
-python_test() {
-       local t
-
-       while IFS= read -r -d '' t
-       do
-               "${PYTHON}" "${t}" || die "${t} failed with ${EPYTHON}"
-       done < <(find -name test.py -print0)
-}
-
-python_install() {
-       local f dest=${D}$(python_get_includedir)/mx
-
-       distutils-r1_python_install \
-               build --build-platlib "${BUILD_DIR}"/lib
-
-       mkdir -p "${dest}" || die
-       while IFS= read -r -d '' f
-       do
-               mv -f "${f}" "${dest}" || die
-       done < <(find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
-}
-
-python_install_all() {
-       local f
-
-       distutils-r1_python_install_all
-
-       dohtml -a html -r mx
-       while IFS= read -r -d '' f
-       do
-               dodoc "${f}"
-       done < <(find -name '*.pdf' -print0)
-}
diff --git a/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch b/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch
deleted file mode 100644 (file)
index 25a95b3..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-reverse or annul them. Either or
-diff -ur egenix-mx-base-3.2.6.orig/mx/DateTime/mxDateTime/testslotops.py egenix-mx-base-3.2.6/mx/DateTime/mxDateTime/testslotops.py
---- mx/DateTime/mxDateTime/testslotops.py      2011-07-26 17:12:50.000000000 +0800
-+++ mx/DateTime/mxDateTime/testslotops.py      2014-03-28 20:18:05.841240713 +0800
-@@ -54,10 +54,10 @@
-     # DateTime op DateTimeDelta
-     assert t1 != td1
-     assert t2 != td1
--    assert t1 < td1
--    assert t2 < td1
--    assert not (t1 > td1)
--    assert not (t2 > td1)
-+    assert t1 > td1
-+    assert t2 > td1
-+    assert not (t1 < td1)
-+    assert not (t2 < td1)
-     # DateTime op floats
-     assert t1 == t1_ticks
-@@ -259,10 +259,10 @@
-     # DateTimeDelta op DateTime
-     assert td1 != t1
-     assert td2 != t1
--    assert td1 > t1
--    assert td2 > t1
--    assert not (td1 < t1)
--    assert not (td2 < t1)
-+#    assert td1 > t1
-+#    assert td2 > t1
-+#    assert not (td1 < t1)
-+#    assert not (td2 < t1)
-     # DateTimeDelta op floats
-     assert td1 == td1_seconds
diff --git a/dev-python/egenix-mx-base/metadata.xml b/dev-python/egenix-mx-base/metadata.xml
deleted file mode 100644 (file)
index 7f4f33c..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="project">
-               <email>python@gentoo.org</email>
-               <name>Python</name>
-       </maintainer>
-</pkgmetadata>
index d93da5e4455f3b19e21ae1639a70909498182ad7..de4a2cf0db7d1755312fd1a5cf50f6866f7e4e4e 100644 (file)
@@ -596,12 +596,6 @@ net-nntp/kwooty
 # Removal in 30 days.  Bug #708352.
 net-im/turses
 
-# Michał Górny <mgorny@gentoo.org> (2020-02-05)
-# NIH utility package, last released 2015.  No Python 3 support.
-# All remaining reverse dependencies are masked for removal.
-# Removal in 30 days.  Bug #708332.
-dev-python/egenix-mx-base
-
 # Joonas Niilola <juippis@gentoo.org> (2020-02-05)
 # Stagnant upstream with latest release from 2016, python2-only, no maintainer
 # in Gentoo, no notable ebuild action in years, multiple bugs open. Blocks