dev-python/nose_fixes: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 19:36:20 +0000 (21:36 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 20:12:54 +0000 (22:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/nose_fixes/nose_fixes-1.3.ebuild

index 5abc2100e901d701e94d6d45b3530ffc993ab683..15b6fcc2314a4b18a0dcc611a043b1fc9a518f56 100644 (file)
@@ -1,9 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_6 pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
 
 inherit distutils-r1
 
@@ -14,10 +15,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="doc"
 
 RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/nose[${PYTHON_USEDEP}]"
 DEPEND="
        ${RDEPEND}
@@ -26,20 +25,6 @@ DEPEND="
                dev-python/pkginfo[${PYTHON_USEDEP}]
        )"
 
-python_prepare_all() {
-       sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
-
-python_test() {
-       nosetests || die
-}
+distutils_enable_sphinx docs \
+       dev-python/pkginfo
+distutils_enable_tests nose