x11-misc/qterm: fix build with Qt 5.11
authorAkinori Hattori <hattya@gentoo.org>
Sat, 18 Aug 2018 02:01:16 +0000 (11:01 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 18 Aug 2018 02:01:16 +0000 (11:01 +0900)
Closes: https://bugs.gentoo.org/663352
Package-Manager: Portage-2.3.40, Repoman-2.3.9

x11-misc/qterm/files/qterm-0.7.1-headers.patch [new file with mode: 0644]
x11-misc/qterm/qterm-0.7.1.ebuild

diff --git a/x11-misc/qterm/files/qterm-0.7.1-headers.patch b/x11-misc/qterm/files/qterm-0.7.1-headers.patch
new file mode 100644 (file)
index 0000000..c442c0a
--- /dev/null
@@ -0,0 +1,40 @@
+--- a/src/keydialog.h
++++ b/src/keydialog.h
+@@ -10,6 +10,7 @@
+ #ifndef KEYDIALOG_H
+ #define KEYDIALOG_H
++#include <QButtonGroup>
+ #include "ui_keydialog.h"
+ namespace QTerm
+ {
+--- a/src/soundconf.h
++++ b/src/soundconf.h
+@@ -1,6 +1,7 @@
+ #ifndef SOUNDCONF_H
+ #define SOUNDCONF_H
++#include <QButtonGroup>
+ #include "ui_soundconf.h"
+ namespace QTerm
+ {
+--- a/src/shortcutsdialog.cpp
++++ b/src/shortcutsdialog.cpp
+@@ -3,6 +3,7 @@
+ #include <QKeyEvent>
+ #include <QMessageBox>
+ #include <QShortcut>
++#include <QAction>
+
+ namespace QTerm {
+
+--- a/src/shortcutsdialog.h
++++ b/src/shortcutsdialog.h
+@@ -3,6 +3,7 @@
+
+ #include "ui_shortcutsdialog.h"
+ class QShortcut;
++class QAction;
+
+ namespace QTerm{
+
index 2273e5d30691458f4367c65297d06e6af301b0b9..daf1248d0cbe1cac33c0b103cf8980a0d38f620d 100644 (file)
@@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
        dev-qt/qthelp:5
        x11-base/xorg-proto"
 
+PATCHES=( "${FILESDIR}"/${P}-headers.patch )
 DOCS=( README.rst RELEASE_NOTES TODO )
 
 src_prepare() {