sys-libs/musl: remove vulnerable world, bug #711276
authorAnthony G. Basile <blueness@gentoo.org>
Tue, 3 Mar 2020 01:44:05 +0000 (20:44 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 3 Mar 2020 01:44:54 +0000 (20:44 -0500)
Closes: https://bugs.gentoo.org/711276
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
sys-libs/musl/Manifest
sys-libs/musl/musl-1.1.23.ebuild [deleted file]

index dbf5d17bdfe9f3609164a12ac9b5950114d71f9f..abcb1a03efe15944770773ed62da98a54a81ee76 100644 (file)
@@ -1,6 +1,5 @@
 DIST getconf.c 11614 BLAKE2B ba49a573fc16d51780a0b0b81fbf7b64a1142f1dbad203c9609a59b6b07e7404f676c415383ae88c0aede95694821f6ee381bffd93cc3330501e17dc07d122bd SHA512 0d80f37b34a35e3d14b012257c50862dfeb9d2c81139ea2dfa101d981d093b009b9fa450ba27a708ac59377a48626971dfc58e20a3799084a65777a0c32cbc7d
 DIST getent.c 9438 BLAKE2B dc20353583c10a001bd8fe8474f32b70254dc56da186d1cdbaf4081570c3d7a10497024da5815a485fc4728adc9eebd270aec99ba93b7546b38c728978e3e00b SHA512 b35de9847353b273516162ed4828a810c6130fc5b7de44ee4433003b3f99647b25792d9b1c40dfc67069add11f3fb850e5c35d4f1912dccac108059bbbdfd5a2
 DIST iconv.c 2577 BLAKE2B 070ca87b30c90ab98c27d5faf7a2fcb64ff7c67ca212ee6072165b2146979c551f714954dbd465462a171837c59b6ea027e0206458a2df0f977e45f01be3ce48 SHA512 9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf
-DIST musl-1.1.23.tar.gz 1013779 BLAKE2B 0251604697f6e243d173c6a72d0a24ddbbce298f8e3a53d9d3a18d7f5ebf19f4e85584a494639c2470530b61c3189150bfaed3376e31acf4e1b2daa1c30860dc SHA512 a2278de9903852b08352d3e734a39d4616caa602496997ba843e8fea0e1c481761776745faf04536a149d1c4af416b68df681b6fbc9ae2de8794e18c2e853b09
 DIST musl-1.1.24.tar.gz 1024988 BLAKE2B 5fa26746eed0f2334b740adf94a8400568d56d9b2276bf1fbac828f9b707b4e215d3c16af9ea048b9d771f1d0a58ada3bc6e1bf0ba8f5fa693f5042fc6af30df SHA512 8987f1e194ea616f34f4f21fe9def28fb7f81d7060e38619206c6349f79db3bbb76bae8b711f5f9b8ed038799c9aea1a4cbec69e0bc4131e246203e133149e77
 DIST musl-1.2.0.tar.gz 1035265 BLAKE2B 0a47e0f438cca0f3ce31ae024c19358160214842115b560efc48e66228055c9147d9550957a79425322d510ba773f197d0944bb844bf6addbbf698088a3358a9 SHA512 58bd88189a6002356728cea1c6f6605a893fe54f7687595879add4eab283c8692c3b031eb9457ad00d1edd082cfe62fcc0eb5eb1d3bf4f1d749c0efa2a95fec1
diff --git a/sys-libs/musl/musl-1.1.23.ebuild b/sys-libs/musl/musl-1.1.23.ebuild
deleted file mode 100644 (file)
index ec3d2f4..0000000
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.musl-libc.org/musl"
-       inherit git-r3
-       SRC_URI="
-       https://dev.gentoo.org/~blueness/musl-misc/getconf.c
-       https://dev.gentoo.org/~blueness/musl-misc/getent.c
-       https://dev.gentoo.org/~blueness/musl-misc/iconv.c"
-       KEYWORDS=""
-else
-       SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz
-       https://dev.gentoo.org/~blueness/musl-misc/getconf.c
-       https://dev.gentoo.org/~blueness/musl-misc/getent.c
-       https://dev.gentoo.org/~blueness/musl-misc/iconv.c"
-       KEYWORDS="-* amd64 arm arm64 ~mips ppc x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
-       if [[ ${CATEGORY} == cross-* ]] ; then
-               export CTARGET=${CATEGORY#cross-}
-       fi
-fi
-
-DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-LICENSE="MIT LGPL-2 GPL-2"
-SLOT="0"
-IUSE="headers-only"
-
-QA_SONAME="/usr/lib/libc.so"
-QA_DT_NEEDED="/usr/lib/libc.so"
-
-is_crosscompile() {
-       [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
-       use headers-only && is_crosscompile
-}
-
-pkg_setup() {
-       if [ ${CTARGET} == ${CHOST} ] ; then
-               case ${CHOST} in
-               *-musl*) ;;
-               *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
-               esac
-       fi
-
-       # fix for #667126, copied from glibc ebuild
-       # make sure host make.conf doesn't pollute us
-       if is_crosscompile || tc-is-cross-compiler ; then
-               CHOST=${CTARGET} strip-unsupported-flags
-       fi
-}
-
-src_configure() {
-       tc-getCC ${CTARGET}
-       just_headers && export CC=true
-
-       local sysroot
-       is_crosscompile && sysroot=/usr/${CTARGET}
-       ./configure \
-               --target=${CTARGET} \
-               --prefix=${sysroot}/usr \
-               --syslibdir=${sysroot}/lib \
-               --disable-gcc-wrapper || die
-}
-
-src_compile() {
-       emake obj/include/bits/alltypes.h
-       just_headers && return 0
-
-       emake
-       if [[ ${CATEGORY} != cross-* ]] ; then
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getconf.c -o "${T}"/getconf || die
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getent.c -o "${T}"/getent || die
-               $(tc-getCC) ${CFLAGS} "${DISTDIR}"/iconv.c -o "${T}"/iconv || die
-       fi
-}
-
-src_install() {
-       local target="install"
-       just_headers && target="install-headers"
-       emake DESTDIR="${D}" ${target}
-       just_headers && return 0
-
-       # musl provides ldd via a sym link to its ld.so
-       local sysroot
-       is_crosscompile && sysroot=/usr/${CTARGET}
-       local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
-       dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
-
-       if [[ ${CATEGORY} != cross-* ]] ; then
-               local arch=$("${D}"usr/lib/libc.so 2>&1 | sed -n '1s/^musl libc (\(.*\))$/\1/p')
-               [[ -e "${D}"/lib/ld-musl-${arch}.so.1 ]] || die
-               cp "${FILESDIR}"/ldconfig.in "${T}" || die
-               sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig || die
-               into /
-               dosbin "${T}"/ldconfig
-               into /usr
-               dobin "${T}"/getconf
-               dobin "${T}"/getent
-               dobin "${T}"/iconv
-               echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl || die
-               doenvd "${T}"/00musl
-       fi
-}
-
-pkg_postinst() {
-       is_crosscompile && return 0
-
-       [ "${ROOT}" != "/" ] && return 0
-
-       ldconfig || die
-}