dev-python/zipp: new pkg, v0.5.1
authorLouis Sautier <sbraz@gentoo.org>
Thu, 4 Jul 2019 11:47:21 +0000 (13:47 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Mon, 8 Jul 2019 09:16:30 +0000 (11:16 +0200)
This is required by dev-python/importlib-metadata which is in turn
required by the new version of dev-python/irc.

Package-Manager: Portage-2.3.67, Repoman-2.3.16
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/zipp/Manifest [new file with mode: 0644]
dev-python/zipp/metadata.xml [new file with mode: 0644]
dev-python/zipp/zipp-0.5.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
new file mode 100644 (file)
index 0000000..778f14e
--- /dev/null
@@ -0,0 +1 @@
+DIST zipp-0.5.1.tar.gz 10763 BLAKE2B 4f70d6ed94203d4b9fb9127930a07797c3cbfa023e0cd472e9d3a18e1877619dbefee654cd0364592a594b6e9e0aabc813e0560695bb18f8e3a64cb4ce76f0e2 SHA512 d4486ae98159677cd481cddb3bd00d5d2237dc94f0f3129b03994800b0e136c12b05e02d2ca7d628043dabce323f34dd919b9ba731549656802527abdcfea120
diff --git a/dev-python/zipp/metadata.xml b/dev-python/zipp/metadata.xml
new file mode 100644 (file)
index 0000000..a0ceea3
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>sbraz@gentoo.org</email>
+               <name>Louis Sautier</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">zipp</remote-id>
+               <remote-id type="github">jaraco/zipp</remote-id>
+               <bugs-to>https://github.com/jaraco/zipp/issues</bugs-to>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/zipp/zipp-0.5.1.ebuild b/dev-python/zipp/zipp-0.5.1.ebuild
new file mode 100644 (file)
index 0000000..2d0e62d
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+       test? (
+               dev-python/contextlib2[${PYTHON_USEDEP}]
+               dev-python/pathlib2[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/unittest2[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+               >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+               dev-python/sphinx[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build docs docs/_build/html || die
+               HTML_DOCS=( docs/_build/html/. )
+       fi
+}
+
+python_test() {
+       pytest -vv || die "tests failed with ${EPYTHON}"
+}