app-i18n/ibus-typing-booster: call gnome2_schemas_update
authorAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 13:38:05 +0000 (22:38 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 16 May 2020 13:38:05 +0000 (22:38 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild
app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild

index a1697767ab8d783f3c0b1b89c5fe5d4290813ed9..ed1abe7454498d69d2638436e9920dfc0de9fc8d 100644 (file)
@@ -5,7 +5,7 @@ EAPI="7"
 PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="sqlite(+)"
 
-inherit python-single-r1 xdg
+inherit gnome2-utils python-single-r1 xdg
 
 DESCRIPTION="Completion input method for IBus"
 HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
@@ -34,12 +34,15 @@ BDEPEND="sys-devel/gettext
 
 pkg_preinst() {
        xdg_pkg_preinst
+       gnome2_schemas_savelist
 }
 
 pkg_postinst() {
        xdg_pkg_postinst
+       gnome2_schemas_update
 }
 
 pkg_postrm() {
        xdg_pkg_postrm
+       gnome2_schemas_update
 }
index a1697767ab8d783f3c0b1b89c5fe5d4290813ed9..ed1abe7454498d69d2638436e9920dfc0de9fc8d 100644 (file)
@@ -5,7 +5,7 @@ EAPI="7"
 PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="sqlite(+)"
 
-inherit python-single-r1 xdg
+inherit gnome2-utils python-single-r1 xdg
 
 DESCRIPTION="Completion input method for IBus"
 HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
@@ -34,12 +34,15 @@ BDEPEND="sys-devel/gettext
 
 pkg_preinst() {
        xdg_pkg_preinst
+       gnome2_schemas_savelist
 }
 
 pkg_postinst() {
        xdg_pkg_postinst
+       gnome2_schemas_update
 }
 
 pkg_postrm() {
        xdg_pkg_postrm
+       gnome2_schemas_update
 }