net-misc/rdesktop: 1.8.4 bump, security fixes
authorBernard Cafarelli <voyageur@gentoo.org>
Fri, 4 Jan 2019 23:00:07 +0000 (00:00 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Fri, 4 Jan 2019 23:00:43 +0000 (00:00 +0100)
This release includes fixes for a set of 21 vulnerabilities in rdesktop
when a malicious RDP server is used

Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
net-misc/rdesktop/Manifest
net-misc/rdesktop/rdesktop-1.8.4.ebuild [new file with mode: 0644]

index 2ceeaa21707d2362e14c29ac00349c0853699738..ba8eea641aa7c0318d30d9b4c65441859025bd7e 100644 (file)
@@ -1 +1,2 @@
 DIST rdesktop-1.8.3.tar.gz 320212 BLAKE2B daca0b78a8fcd0461f1c3251135bd980aaafacf8e0cd51ab731b576adb23006ec9f51858586e7e3a1a7f192b7830308e585984b4a31fb013748f8c6b3a8c47bb SHA512 06b94ad3b09430b05e424ef31a3e6f2388190b4920e348603cb66a414244896e0dc8906b9f12920e9406cf153ffa7f6507b23bf6713c3a675c0540a8ef57902d
+DIST rdesktop-1.8.4.tar.gz 321448 BLAKE2B b4d5a91f77a63258d08823c860b2d7045b0ee7ad0feb144746c904146c410c6456391eb3f2b7b9a6a40c2fb34515bb7518888c2c9da8dfcaf17c5309ff21cad3 SHA512 9e4f6723eb0baab31ad11f1c5c29a4753c655386c2381d01646b7834c959ffc2ec1e0c2f3f73626255aa018889709758d97387c7563da98bb1b7f269610929ae
diff --git a/net-misc/rdesktop/rdesktop-1.8.4.ebuild b/net-misc/rdesktop/rdesktop-1.8.4.ebuild
new file mode 100644 (file)
index 0000000..f5be605
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://www.rdesktop.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa ao debug ipv6 kerberos libressl libsamplerate oss pcsc-lite xrandr"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:= )
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXau
+       x11-libs/libXdmcp
+       alsa? ( media-libs/alsa-lib )
+       ao? ( >=media-libs/libao-0.8.6 )
+       kerberos? ( net-libs/libgssglue )
+       libsamplerate? ( media-libs/libsamplerate )
+       pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
+       xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+       x11-libs/libXt"
+BDEPEND=virtual/pkgconfig
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
+       "${FILESDIR}"/${PN}-1.8.3-no_strip.patch
+       "${FILESDIR}"/${PN}-1.8.3-xrandr_configure.patch
+)
+
+DOCS=( doc/HACKING doc/TODO doc/keymapping.txt )
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       if use ao; then
+               sound_conf=$(use_with ao sound libao)
+       else if use alsa; then
+                       sound_conf=$(use_with alsa sound alsa)
+               else
+                       sound_conf=$(use_with oss sound oss)
+               fi
+       fi
+
+       econf \
+               --with-openssl="${EPREFIX}"/usr \
+               $(use_with debug) \
+               $(use_with ipv6) \
+               $(use_with libsamplerate) \
+               $(use_with xrandr) \
+               $(use_enable kerberos credssp) \
+               $(use_enable pcsc-lite smartcard) \
+               ${sound_conf}
+}