app-crypt/acme-client: New ebuild
authorCédric Krier <cedk@gentoo.org>
Sat, 12 Aug 2017 16:38:33 +0000 (18:38 +0200)
committerCédric Krier <cedk@gentoo.org>
Sat, 12 Aug 2017 16:39:18 +0000 (18:39 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

app-crypt/acme-client/Manifest [new file with mode: 0644]
app-crypt/acme-client/acme-client-0.1.16.ebuild [new file with mode: 0644]
app-crypt/acme-client/metadata.xml [new file with mode: 0644]

diff --git a/app-crypt/acme-client/Manifest b/app-crypt/acme-client/Manifest
new file mode 100644 (file)
index 0000000..9b8d275
--- /dev/null
@@ -0,0 +1 @@
+DIST acme-client-portable-0.1.16.tgz 53129 SHA256 e9e705a362f6d450f4a229b34199cfb8022b8268cb86accf75d6b5b0c62a0003 SHA512 730c20bdf9d72b24e66c54b009a282e04da3ea8ce3b9eb053750672c53c9586b2879d87a565ddbab033d7ba6a577dd6399313b20cf654b185905db4de988b6b7 WHIRLPOOL 3a8972ece2dcd5a700e0c49c9eea03430789b7e32d51ffc1952c7fd011fe1bdae7fe1f521741b271b7abf043444efec62df806ca4ef602379415c421b8557d50
diff --git a/app-crypt/acme-client/acme-client-0.1.16.ebuild b/app-crypt/acme-client/acme-client-0.1.16.ebuild
new file mode 100644 (file)
index 0000000..938a037
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="a secure ACME client"
+HOMEPAGE="https://kristaps.bsd.lv/acme-client"
+SRC_URI="https://kristaps.bsd.lv/acme-client/snapshots/${PN}-portable-${PV}.tgz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       dev-libs/libressl
+       dev-libs/libbsd"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-portable-${PV}
+
+src_compile() {
+       emake CC=$(tc-getCC)
+}
+
+src_install() {
+       DESTDIR="${D}" PREFIX="/usr" MAN1DIR="/usr/share/man/man1" emake install
+       dodoc ChangeLog
+}
diff --git a/app-crypt/acme-client/metadata.xml b/app-crypt/acme-client/metadata.xml
new file mode 100644 (file)
index 0000000..86cb5dc
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>cedk@gentoo.org</email>
+               <name>Cédric Krier</name>
+       </maintainer>
+       <longdescription lang="en">
+               acme-client is a client for Let's Encrypt users, but one designed for
+               security. No Python. No Ruby. No Bash. A straightforward, open source
+               implementation in C that isolates each step of the sequence.
+       </longdescription>
+</pkgmetadata>