dont compress manpages
authorMike Frysinger <vapier@gentoo.org>
Fri, 26 Jan 2007 08:50:44 +0000 (08:50 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 26 Jan 2007 08:50:44 +0000 (08:50 +0000)
Package-Manager: portage-2.1.2-r3

net-misc/netkit-bootpd/netkit-bootpd-0.17-r1.ebuild
net-misc/netkit-routed/files/digest-netkit-routed-0.17-r3
net-misc/netkit-routed/netkit-routed-0.17-r3.ebuild
net-misc/netkit-rwall/files/digest-netkit-rwall-0.17
net-misc/netkit-rwall/netkit-rwall-0.17.ebuild
net-misc/netkit-talk/files/digest-netkit-talk-0.17-r4
net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild
net-misc/netkit-telnetd/netkit-telnetd-0.17-r6.ebuild
net-misc/netkit-telnetd/netkit-telnetd-0.17-r7.ebuild
net-misc/netkit-telnetd/netkit-telnetd-0.17-r8.ebuild

index ce6078b03071547d1f4b79b0e2694c71b6edf58f..3f8a4678abf3b865ee7336264392fb68c70e1a70 100644 (file)
@@ -1,17 +1,17 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-bootpd/netkit-bootpd-0.17-r1.ebuild,v 1.22 2006/06/04 12:26:44 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-bootpd/netkit-bootpd-0.17-r1.ebuild,v 1.23 2007/01/26 08:43:25 vapier Exp $
 
 MY_PN=${PN/pd/paramd}
 S=${WORKDIR}/${MY_PN}-${PV}
 DESCRIPTION="Netkit - bootp"
-SRC_URI="mirror://debian/pool/main/n/netkit-bootparamd/${MY_PN}_${PV}.orig.tar.gz"
 HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="mirror://debian/pool/main/n/netkit-bootparamd/${MY_PN}_${PV}.orig.tar.gz"
 
-KEYWORDS="x86 sparc ppc mips"
-IUSE=""
 LICENSE="BSD"
 SLOT="0"
+KEYWORDS="x86 sparc ppc mips"
+IUSE=""
 
 src_compile() {
        ./configure || die
@@ -20,10 +20,10 @@ src_compile() {
 
 src_install() {
        into /usr
-       dosbin rpc.bootparamd/bootparamd
+       dosbin rpc.bootparamd/bootparamd || die
        dosym bootparamd /usr/sbin/rpc.bootparamd
        doman rpc.bootparamd/bootparamd.8
-       dosym bootparamd.8.gz /usr/share/man/man8/rpc.bootparamd.8.gz
+       dosym bootparamd.8 /usr/share/man/man8/rpc.bootparamd.8
        doman rpc.bootparamd/bootparams.5
        dodoc README ChangeLog
        newdoc rpc.bootparamd/README README.bootparamd
index 5ac45fad5be7ec3266b3bbfb2f61a30b8d5ffa78..bfd1ab5ed3de77520f7702a3c717a291cd078ed7 100644 (file)
@@ -1 +1,3 @@
 MD5 3a9507876db23109be6d1f41ced5570a netkit-routed_0.17.orig.tar.gz 36435
+RMD160 a3e86edeaec38bea994996e600956358bff926e7 netkit-routed_0.17.orig.tar.gz 36435
+SHA256 0d6e7eb31e2ece9eccca1e0cbf01425b8a749bf08b83fbacad4164cc67784824 netkit-routed_0.17.orig.tar.gz 36435
index 249cbb15d6ff01526289996ee3bce373e1d1c64a..3ed9fa71d40870f996f78ae9b4bd423c7add95df 100644 (file)
@@ -1,15 +1,15 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-routed/netkit-routed-0.17-r3.ebuild,v 1.5 2004/07/15 03:07:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-routed/netkit-routed-0.17-r3.ebuild,v 1.6 2007/01/26 08:46:39 vapier Exp $
 
 DESCRIPTION="Netkit - routed"
-SRC_URI="mirror://debian/pool/main/n/netkit-routed/${PN}_${PV}.orig.tar.gz"
 HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+SRC_URI="mirror://debian/pool/main/n/netkit-routed/${PN}_${PV}.orig.tar.gz"
 
-KEYWORDS="x86 sparc ppc mips alpha"
-IUSE=""
 LICENSE="BSD"
 SLOT="0"
+KEYWORDS="x86 sparc ppc mips alpha"
+IUSE=""
 
 src_compile() {
        ./configure || die
@@ -17,25 +17,21 @@ src_compile() {
 }
 
 src_install() {
-       into /usr
-
        # ripquery
-       dosbin ripquery/ripquery
+       dosbin ripquery/ripquery || die
        doman ripquery/ripquery.8
 
        # routed
-       dosbin routed/routed
+       dosbin routed/routed || die
        dosym routed /usr/sbin/in.routed
        doman routed/routed.8
-       dosym routed.8.gz /usr/share/man/man8/in.routed.8.gz
+       dosym routed.8 /usr/share/man/man8/in.routed.8
 
        # docs
        dodoc README ChangeLog
        newdoc routed/README README.routed
 
        # init scripts
-       insinto /etc/conf.d
-       newins "${FILESDIR}/routed.confd" routed
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/routed.initd" routed
+       newconfd "${FILESDIR}"/routed.confd routed
+       newinitd "${FILESDIR}"/routed.initd routed
 }
index c0f972c707ae999f8e0963a126c747e003786ab5..22676f7a230f8dfc93f4ab425296305373c3ba81 100644 (file)
@@ -1 +1,3 @@
 MD5 c7a85262fc9911e0574ce5706ce69369 netkit-rwall-0.17.tar.gz 11861
+RMD160 3a48913545cc28811b46b0ee2f2e246ff6b10325 netkit-rwall-0.17.tar.gz 11861
+SHA256 97bd59f787d19bc3dff633d35eeb627176574aa7adf65b64a6a4d8dc08f752ed netkit-rwall-0.17.tar.gz 11861
index b7ffb3a8a63985c8966ba5964b4d5efb5fc656ad..85ca4c692d185ca78c3d45fe471bf366ec486d4f 100644 (file)
@@ -1,30 +1,29 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rwall/netkit-rwall-0.17.ebuild,v 1.2 2004/10/24 09:53:19 wmertens Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-rwall/netkit-rwall-0.17.ebuild,v 1.3 2007/01/26 08:48:29 vapier Exp $
 
 DESCRIPTION="Netkit - rwall"
-SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
 HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
-KEYWORDS="~x86"
-SLOT="0"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+
 LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
 IUSE=""
 
-DEPEND="virtual/libc"
+DEPEND=""
 
 src_compile() {
        ./configure || die
-       mv MCONFIG MCONFIG.ori
-       sed -e "s:-O2 -Wall:-Wall:" -e "s:-Wpointer-arith::" MCONFIG.ori > MCONFIG
+       sed -i -e "s:-O2 -Wall:-Wall:" -e "s:-Wpointer-arith::" MCONFIG
        emake || die
 }
 
 src_install() {
-       into /usr
-       dobin  rwall/rwall
-       doman  rwall/rwall.1
-       dosbin rpc.rwalld/rwalld
-       doman  rpc.rwalld/rpc.rwalld.8
-       dosym  rpc.rwalld.8.gz /usr/share/man/man8/rwall.8.gz
-       dodoc  README ChangeLog BUGS
+       dobin rwall/rwall || die
+       doman rwall/rwall.1
+       dosbin rpc.rwalld/rwalld || die
+       doman rpc.rwalld/rpc.rwalld.8
+       dosym rpc.rwalld.8 /usr/share/man/man8/rwall.8
+       dodoc README ChangeLog BUGS
 }
index 639c1820f9f219bf6f1fc3121e120d8fb6a91e2d..edfa5cbfc7db18edd9755b56e8c6258ec79a5292 100644 (file)
@@ -1 +1,3 @@
 MD5 e3c57208f8644ae206dab5e236daf7b3 netkit-ntalk-0.17.tar.gz 37396
+RMD160 70f43d927775e278d8f1182f150da28031de339c netkit-ntalk-0.17.tar.gz 37396
+SHA256 d8f614e8d4d7981a0adf0f84d2d3954018d5fe0e57a8e5731256d66cbcf45e90 netkit-ntalk-0.17.tar.gz 37396
index b3282fc299de9568ab5522608dc7b1504c4db54a..317d50f1c2fa55fe8278d59e0d94c075d3a2fcad 100644 (file)
@@ -1,11 +1,9 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild,v 1.13 2004/10/04 22:14:01 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild,v 1.14 2007/01/26 08:48:48 vapier Exp $
 
 inherit eutils
 
-IUSE="ipv6"
-
 MY_P=netkit-ntalk-${PV}
 S=${WORKDIR}/netkit-ntalk-${PV}
 
@@ -16,33 +14,31 @@ SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="x86 ppc sparc alpha mips ~amd64"
+IUSE="ipv6"
 
-DEPEND="virtual/libc
-       >=sys-libs/ncurses-5.2"
+DEPEND=">=sys-libs/ncurses-5.2"
 
 src_unpack() {
        unpack ${A}
-       epatch ${FILESDIR}/${PF}-gentoo.diff
-       cd ${S}
-       use ipv6 && epatch ${FILESDIR}/${P}-ipv6.diff
+       epatch "${FILESDIR}"/${PF}-gentoo.diff
+       cd "${S}"
+       use ipv6 && epatch "${FILESDIR}"/${P}-ipv6.diff
 }
 
 src_compile() {
        ./configure || die
-       cp MCONFIG MCONFIG.orig
-       sed -e "s:-O2 -Wall:-Wall:" -e "s:-Wpointer-arith::" MCONFIG.orig > MCONFIG
+       sed -i -e "s:-O2 -Wall:-Wall:" -e "s:-Wpointer-arith::" MCONFIG
        make || die
 }
 
 src_install() {
        insinto /etc/xinetd.d
-       newins ${FILESDIR}/talk.xinetd talk
-       into /usr
-       dobin talk/talk
+       newins "${FILESDIR}"/talk.xinetd talk
+       dobin talk/talk || die
        doman talk/talk.1
-       dosbin talkd/talkd
+       dosbin talkd/talkd || die
        dosym talkd /usr/sbin/in.talkd
        doman talkd/talkd.8
-       dosym talkd.8.gz /usr/share/man/man8/in.talkd.8.gz
+       dosym talkd.8 /usr/share/man/man8/in.talkd.8
        dodoc README ChangeLog BUGS
 }
index 0757d64d7a49ed884dbbbe823287a14ee9d36721..f1e5c1e677181de16bde2537e69e0593d376b706 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r6.ebuild,v 1.13 2007/01/22 20:32:24 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r6.ebuild,v 1.14 2007/01/26 08:50:44 vapier Exp $
 
 inherit eutils
 
@@ -64,7 +64,7 @@ src_install() {
        doman telnet/telnet.1
        doman telnetd/*.8
        doman telnetd/issue.net.5
-       dosym telnetd.8.gz /usr/share/man/man8/in.telnetd.8.gz
+       dosym telnetd.8 /usr/share/man/man8/in.telnetd.8
        doman telnetlogin/telnetlogin.8
        dodoc BUGS ChangeLog README
        dodoc ${FILESDIR}/net.issue.sample
index 7908576c8673ef835f323082826caa8d2ff69248..6b9df37c2b180f320c2c7343341b7accf1e146de 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r7.ebuild,v 1.3 2007/01/22 20:32:24 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r7.ebuild,v 1.4 2007/01/26 08:50:44 vapier Exp $
 
 inherit eutils toolchain-funcs
 
@@ -68,7 +68,7 @@ src_install() {
        doman telnet/telnet.1
        doman telnetd/*.8
        doman telnetd/issue.net.5
-       dosym telnetd.8.gz /usr/share/man/man8/in.telnetd.8.gz
+       dosym telnetd.8 /usr/share/man/man8/in.telnetd.8
        doman telnetlogin/telnetlogin.8
        dodoc BUGS ChangeLog README
        dodoc ${FILESDIR}/net.issue.sample
index f01063d4bb85f1d77c3118cb68d5e498e3ee6220..1caae25b0295dcab7c21a8c73dc3f49619297af9 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r8.ebuild,v 1.1 2007/01/22 20:32:24 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-telnetd/netkit-telnetd-0.17-r8.ebuild,v 1.2 2007/01/26 08:50:44 vapier Exp $
 
 inherit eutils toolchain-funcs
 
@@ -15,7 +15,7 @@ SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="build"
+IUSE=""
 
 DEPEND=">=sys-libs/ncurses-5.2
        !net-misc/telnet-bsd"
@@ -24,7 +24,7 @@ S=${WORKDIR}/netkit-telnet-${PV}
 
 src_unpack() {
        unpack ${A}
-       cd ${S}
+       cd "${S}"
        # Patch: [0]
        # Gentoo lacks a maintainer for this package right now. And a 
        # security problem arose. While reviewing our options for how 
@@ -32,14 +32,13 @@ src_unpack() {
        # better to just stay in sync with debian's own netkit-telnet 
        # package. Lots of bug fixes by them over time which were not in 
        # our telnetd.
-       epatch ${WORKDIR}/netkit-telnet_0.17-${PATCHLEVEL}.diff || die
+       epatch "${WORKDIR}"/netkit-telnet_0.17-${PATCHLEVEL}.diff
 
        # Patch: [1]
        # after the deb patch we need to add a small patch that defines 
        # gnu source. This is needed for gcc-3.4.x (needs to be pushed 
        # back to the deb folk?)
-       epatch ${FILESDIR}/netkit-telnetd-0.17-cflags-gnu_source.patch \
-               || die
+       epatch "${FILESDIR}"/netkit-telnetd-0.17-cflags-gnu_source.patch
 }
 
 src_compile() {
@@ -59,8 +58,6 @@ src_compile() {
 
 src_install() {
        dobin telnet/telnet || die
-       #that's it if we're going on a build image
-       use build && return 0
 
        dosbin telnetd/telnetd || die
        dosym telnetd /usr/sbin/in.telnetd
@@ -68,12 +65,12 @@ src_install() {
        doman telnet/telnet.1
        doman telnetd/*.8
        doman telnetd/issue.net.5
-       dosym telnetd.8.gz /usr/share/man/man8/in.telnetd.8.gz
+       dosym telnetd.8 /usr/share/man/man8/in.telnetd.8
        doman telnetlogin/telnetlogin.8
        dodoc BUGS ChangeLog README
-       dodoc ${FILESDIR}/net.issue.sample
+       dodoc "${FILESDIR}"/net.issue.sample
        newdoc telnet/README README.telnet
        newdoc telnet/TODO TODO.telnet
        insinto /etc/xinetd.d
-       newins ${FILESDIR}/telnetd.xinetd telnetd
+       newins "${FILESDIR}"/telnetd.xinetd telnetd
 }