sys-cluster/cman-lib: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 22:07:38 +0000 (23:07 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 22:18:14 +0000 (23:18 +0100)
Bug: https://bugs.gentoo.org/697176
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild

index b3b168af577e356962e497bd15523a85573f6448..3bf3a08a2cd94cdef39333293a2c2b4fcdec7587 100644 (file)
@@ -1,14 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils versionator multilib
+inherit toolchain-funcs
 
 MY_P=cluster-${PV}
-
-MAJ_PV=$(get_major_version)
-MIN_PV=$(get_version_component_range 2).$(get_version_component_range 3)
+MAJ_PV=$(ver_cut 1)
+MIN_PV=$(ver_cut 2-3)
 
 DESCRIPTION="A library for cluster management common to the various pieces of Cluster Suite"
 HOMEPAGE="https://sourceware.org/cluster/wiki/"
@@ -26,23 +25,21 @@ RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_P}/${PN/-//}
 
-src_compile() {
-       (cd "${WORKDIR}"/${MY_P};
-               ./configure \
-                       --cc="$(tc-getCC)" \
-                       --libdir=/usr/$(get_libdir) \
-                       --cflags="-Wall" \
-                       --disable_kernel_check \
-                       --somajor="$MAJ_PV" \
-                       --sominor="$MIN_PV" \
-       ) || die "configure problem"
+src_configure() {
+       cd "${WORKDIR}"/${MY_P} || die
+       ./configure \
+               --cc="$(tc-getCC)" \
+               --libdir=/usr/$(get_libdir) \
+               --cflags="-Wall" \
+               --disable_kernel_check \
+               --somajor="$MAJ_PV" \
+               --sominor="$MIN_PV" \
+               || die "configure problem"
 
        sed -e 's:\($(CC)\):\1 $(LDFLAGS):' \
                -i Makefile "${WORKDIR}/${MY_P}/make/cobj.mk" || die
-
-       emake clean all || die
 }
 
-src_install() {
-       emake DESTDIR="${D}" install || die
+src_compile() {
+       emake clean all
 }