version bump
authorSlawomir Lis <slis@gentoo.org>
Mon, 27 Jun 2016 06:41:02 +0000 (08:41 +0200)
committerSlawomir Lis <slis@gentoo.org>
Mon, 27 Jun 2016 06:41:02 +0000 (08:41 +0200)
Package-Manager: portage-2.3.0_rc1

dev-python/django-mptt/Manifest
dev-python/django-mptt/django-mptt-0.8.4.ebuild [new file with mode: 0644]
dev-python/django-mptt/files/exclude_tests.patch [new file with mode: 0644]

index 9cbef34ac42c1f0eaab8cd0f161f158aaf7b9ebf..018a91487204d5489a9470369211c396e68406d9 100644 (file)
@@ -1 +1,2 @@
 DIST django-mptt-0.7.4.tar.gz 133855 SHA256 8e986aaf458aaf78c87dc316095cc4a951f3ec1d73f81b237107161fa3ea4ad0 SHA512 596bb1b7f4a99b4b8788b3f4da59850bdaaed4214f877479a89ce9f749f9d217f2ccce488e7f67cd75780ace09d3b73fdca2b0d95a56225d63dfb9e6a1d290b6 WHIRLPOOL 26f68b368176868f051534e977a6f73612a8ddf7f54b8292e8ac67307a08aa1522eca68f0dde5c800ea2e0ea0538308955e0c3fd73ff50fc735c665669a797d4
+DIST django-mptt-0.8.4.tar.gz 119207 SHA256 11445b7b12922fe1d3205baf06e1420ec018bccb4ede486c4a5694cf303ee76e SHA512 c3f45813d3dcaf6ce2504941602b1d1fc2a33f13802b34a9c85685dd0e4066a3e8c6fc36be320c472d93efa54a2f10c493b536f45d16a5ab88a08f6baf0513d3 WHIRLPOOL 0c62341bb916bc91d37d08b6db432071dbdc1093ab9960463e0464cf393118719eec88ed4d42bb178674a114b8d8b7f7965575e92ac1cc3308204cd8ff4f8202
diff --git a/dev-python/django-mptt/django-mptt-0.8.4.ebuild b/dev-python/django-mptt/django-mptt-0.8.4.ebuild
new file mode 100644 (file)
index 0000000..9cca9cc
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utilities for implementing Modified Preorder Tree Traversal"
+HOMEPAGE="https://pypi.python.org/pypi/django-mptt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/django-1.8
+"
+
+DEPEND="
+       ${RDEPEND}
+       dev-python/setuptools
+"
+
+src_prepare() {
+       epatch "${FILESDIR}/exclude_tests.patch"
+}
diff --git a/dev-python/django-mptt/files/exclude_tests.patch b/dev-python/django-mptt/files/exclude_tests.patch
new file mode 100644 (file)
index 0000000..36b5ad4
--- /dev/null
@@ -0,0 +1,11 @@
+--- setup.py.orig      2016-06-27 08:09:57.408674058 +0200
++++ setup.py   2016-06-27 08:10:31.112007190 +0200
+@@ -12,7 +12,7 @@
+     author_email='craig.ds@gmail.com',
+     url='http://github.com/django-mptt/django-mptt',
+     license='MIT License',
+-    packages=find_packages(),
++    packages=find_packages(exclude=('tests', 'tests.*',)),
+     include_package_data=True,
+     install_requires=(
+         'Django>=1.8',