net-libs/nghttp2: Minor adjustments
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 08:07:45 +0000 (10:07 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 08:47:38 +0000 (10:47 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-libs/nghttp2/nghttp2-1.39.1.ebuild
net-libs/nghttp2/nghttp2-9999.ebuild

index 970e71d4a9941b602f920f6626156ef929b4f42e..92ac11a357a6bbc0f13f27dd5be02cabdad1780e 100644 (file)
@@ -5,14 +5,14 @@
 
 EAPI=7
 
-inherit autotools multilib-minimal
+inherit multilib-minimal
 
 if [[ ${PV} == 9999 ]] ; then
        EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
-       inherit git-r3
+       inherit autotools git-r3
 else
        SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
 fi
 
 DESCRIPTION="HTTP/2 C Library"
@@ -31,10 +31,7 @@ RDEPEND="
                ${SSL_DEPEND}
                dev-libs/boost:=[${MULTILIB_USEDEP},threads]
        )
-       hpack-tools? (
-               >=dev-libs/jansson-2.5
-               >=net-libs/http-parser-2.9.1:=
-       )
+       hpack-tools? ( >=dev-libs/jansson-2.5 )
        jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
        utils? (
                ${SSL_DEPEND}
@@ -49,7 +46,7 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        default
-       eautoreconf
+       [[ ${PV} == 9999 ]] && eautoreconf
 }
 
 multilib_src_configure() {
index 0950bfb1def247dc66bccb5cca0b2c81dee93360..92ac11a357a6bbc0f13f27dd5be02cabdad1780e 100644 (file)
@@ -53,9 +53,9 @@ multilib_src_configure() {
        local myeconfargs=(
                --disable-examples
                --disable-failmalloc
+               --disable-python-bindings
                --disable-werror
                --without-cython
-               --disable-python-bindings
                $(use_enable cxx asio-lib)
                $(use_enable debug)
                $(multilib_native_use_enable hpack-tools)