dev-ruby/optionable: initial import
authorHans de Graaff <graaff@gentoo.org>
Wed, 12 Aug 2015 05:20:43 +0000 (07:20 +0200)
committerHans de Graaff <graaff@gentoo.org>
Wed, 12 Aug 2015 05:21:03 +0000 (07:21 +0200)
New dependency for forthcoming dev-ruby/moped.

Package-Manager: portage-2.2.20

dev-ruby/optionable/Manifest [new file with mode: 0644]
dev-ruby/optionable/metadata.xml [new file with mode: 0644]
dev-ruby/optionable/optionable-0.2.0.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/optionable/Manifest b/dev-ruby/optionable/Manifest
new file mode 100644 (file)
index 0000000..55ed4c6
--- /dev/null
@@ -0,0 +1 @@
+DIST optionable-0.2.0.gem 9216 SHA256 878859afbf5f681c69bde1bee120f44c13ce570fc6d2430e29a517de8ad34b20 SHA512 4c633c83cd51fb2f1771f5f842cc8024d769f644d513a8d4486c7960d2bdda81be44746a7bb4604bb458cd58c3bbb5db28cb426d25cded6098263798f7daa465 WHIRLPOOL f7f4101fbc86ecea608014eee003fdc06832e911308137c6aeeee1519081bf7fc37ae0382eded3c41f4b01c65c13a615cff37c452e44710b995b8e2c35157740
diff --git a/dev-ruby/optionable/metadata.xml b/dev-ruby/optionable/metadata.xml
new file mode 100644 (file)
index 0000000..822a9ae
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>ruby</herd>
+  <upstream>
+    <remote-id type="github">durran/optionable</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/optionable/optionable-0.2.0.ebuild b/dev-ruby/optionable/optionable-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..71606a5
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Robust options validation for Ruby methods"
+HOMEPAGE="https://github.com/durran/optionable"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""