dev-python/ratelimit: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 09:04:16 +0000 (11:04 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 10:17:00 +0000 (12:17 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/ratelimit/ratelimit-1.4.1.ebuild

index bc4af83a74e601460a16e0a07f6a293195fb6d11..6974189b99e6cda3cc792896cf7f5c77e2bc0a83 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -13,18 +13,11 @@ HOMEPAGE="https://github.com/tomasbasham/ratelimit"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-DEPEND="
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+distutils_enable_tests pytest
 
 src_prepare() {
        default
        # remove --cov args injection
        rm pytest.ini || die
 }
-
-python_test() {
-       pytest || die
-}