sys-devel/clang-common: Add 9.0 branch live ebuild
authorMichał Górny <mgorny@gentoo.org>
Sun, 21 Jul 2019 07:13:19 +0000 (09:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 21 Jul 2019 07:33:44 +0000 (09:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-common/clang-common-9.0.9999.ebuild [new file with mode: 0644]

diff --git a/sys-devel/clang-common/clang-common-9.0.9999.ebuild b/sys-devel/clang-common/clang-common-9.0.9999.ebuild
new file mode 100644 (file)
index 0000000..f8f3bfc
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+       https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_90"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+       newbashcomp utils/bash-autocomplete.sh clang
+}