media-plugins/vdr-dvbhddevice: version bump to 2.2.0
authorMartin Dummer <martin.dummer@gmx.net>
Thu, 8 Nov 2018 16:42:01 +0000 (17:42 +0100)
committerMatthias Schwarzott <zzam@gentoo.org>
Sat, 31 Aug 2019 17:36:50 +0000 (19:36 +0200)
new version 2.2.0
new SRC_URI and HOMEPAGE
fix compile error "... AUDIO_GET_PTS undeclared" with kernel >=4.17
add proxy-maintainer

Signed-off-by: Martin Dummer <martin.dummer@gmx.net>
Closes: https://bugs.gentoo.org/635370
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Closes: https://github.com/gentoo/gentoo/pull/10365
Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
media-plugins/vdr-dvbhddevice/Manifest
media-plugins/vdr-dvbhddevice/files/define_AUDIO_GET_PTS.patch [new file with mode: 0644]
media-plugins/vdr-dvbhddevice/metadata.xml
media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild [new file with mode: 0644]

index f130e50c4da96f0a2474e9e8fd2622b329ff3221..692433b91d7ce24bf594db3b073b9140e558280d 100644 (file)
@@ -1,2 +1,3 @@
 DIST dvbhddevice-2.1.3_p20140115.tar.gz 40424 BLAKE2B 99d5fece7557c7c9f2b0174c9b1f01ac7628f0f0b6aa954f3e829de4653e10cbed6d0516b966f69737aff9ffafd224b3558bd868e972b64ab60c965ba569555a SHA512 29729325affec5e1330cf361a0c82ee5ef9f48f9a6a5032881b331a6451c05c8d99831c43e3eb08129053a7549dd4cd73a5e0afc6fe04d35956c8fecad48d2f4
 DIST vdr-dvbhddevice-2.1.6_p20141116.tar.gz 40902 BLAKE2B 60829c76226c1f0254ac6cdd940fcbcbf08d4cf0a50bfd9ab992db80f63f07389ab29cd4a04aec6319744a39e86cce7dbfee240ab77e819726facd9dbc6d7964 SHA512 0189cf5bfd1d9648915ec65427b4eeeb85ac80281a07a910e65381d86913c37d5840abd8984f17028afe63eae457c7ce398a446e3ad4b70ae4deada316c14b5b
+DIST vdr-dvbhddevice-2.2.0_p20180420.tar.gz 42772 BLAKE2B c70842be34181b15aab69f5a62ba98f4cc72ad5148db684a45ae5c6b74431517b70cda72dbfb6abc371675fd2742f86000b02c645bfba5b6a6b64817f5c59b35 SHA512 bc6ede24897a7704ecefcfdca92eeaf1bf9f8ed2410a478a21cc712730bfe94616c01379a172214f664481fba636ee3aea33540a6cf258597015dfb73720c408
diff --git a/media-plugins/vdr-dvbhddevice/files/define_AUDIO_GET_PTS.patch b/media-plugins/vdr-dvbhddevice/files/define_AUDIO_GET_PTS.patch
new file mode 100644 (file)
index 0000000..4107608
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/dvbhdffdevice.h  2018-10-10 09:03:47.464147905 +0200
++++ b/dvbhdffdevice.h  2018-10-10 09:04:59.353350738 +0200
+@@ -4,6 +4,9 @@
+  * See the README file for copyright information and how to reach the author.
+  */
++#ifndef AUDIO_GET_PTS
++#define AUDIO_GET_PTS              _IOR('o', 19, __u64)
++#endif
+ #ifndef __DVBHDFFDEVICE_H
+ #define __DVBHDFFDEVICE_H
index 2223ff4c5ead2dc5d1d8e1e18050ae629df935f3..25143612c4709d927b8d56d75dbae9216bdc191c 100644 (file)
@@ -1,11 +1,19 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <maintainer type="project">
-    <email>vdr@gentoo.org</email>
-    <name>Gentoo VDR Project</name>
-  </maintainer>
-  <upstream>
-    <remote-id type="bitbucket">powARman/dvbhddevice</remote-id>
-  </upstream>
+       <maintainer type="person">
+               <email>martin.dummer@gmx.net</email>
+               <name>Martin Dummer</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>vdr@gentoo.org</email>
+               <name>Gentoo VDR Project</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="bitbucket">powARman/dvbhddevice</remote-id>
+       </upstream>
 </pkgmetadata>
diff --git a/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild b/media-plugins/vdr-dvbhddevice/vdr-dvbhddevice-2.2.0_p20180420.ebuild
new file mode 100644 (file)
index 0000000..9f21531
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+HG_REVISION="2ea854ae8c7a"
+HG_REVISION_DATE="20180420"
+
+DESCRIPTION="VDR Plugin: output device for the 'Full Featured' TechnoTrend
+S2-6400 DVB Card"
+HOMEPAGE="https://bitbucket.org/powARman/dvbhddevice"
+SRC_URI="https://bitbucket.org/powARman/dvbhddevice/get/${HG_REVISION}.tar.gz ->
+               ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/powARman-${VDRPLUGIN}-${HG_REVISION}"
+
+src_prepare() {
+       vdr-plugin-2_src_prepare
+
+       eapply "${FILESDIR}/define_AUDIO_GET_PTS.patch"
+       fix_vdr_libsi_include dvbhdffdevice.c
+}
+
+src_install() {
+       vdr-plugin-2_src_install
+
+       doheader dvbhdffdevice.h hdffcmd.h
+       insinto /usr/include/libhdffcmd
+       doins libhdffcmd/*.h
+}