media-tv/kodi: Add udf support
authorCraig Andrews <candrews@gentoo.org>
Thu, 16 Apr 2020 16:21:03 +0000 (12:21 -0400)
committerCraig Andrews <candrews@gentoo.org>
Thu, 16 Apr 2020 16:21:26 +0000 (12:21 -0400)
See: https://github.com/xbmc/xbmc/commit/9cd808e
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-tv/kodi/kodi-9999.ebuild
media-tv/kodi/metadata.xml

index fb8da11b53f7a4301a73c59ded88ef9e2dbb96c9..d61653edb8530c7ec5e427abbfca8502827d39f8 100644 (file)
@@ -39,12 +39,13 @@ SLOT="0"
 # use flag is called libusb so that it doesn't fool people in thinking that
 # it is _required_ for USB support. Otherwise they'll disable udev and
 # that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dbus dvd gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl pulseaudio raspberry-pi samba systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dbus dvd gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl pulseaudio raspberry-pi samba systemd +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
 REQUIRED_USE="
        ${PYTHON_REQUIRED_USE}
        || ( gles opengl )
        ^^ ( gbm raspberry-pi wayland X )
        ?? ( mariadb mysql )
+       bluray? ( udf )
        udev? ( !libusb )
        udisks? ( dbus )
        upower? ( dbus )
@@ -110,6 +111,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
        pulseaudio? ( media-sound/pulseaudio )
        samba? ( >=net-fs/samba-3.4.6[smbclient(+)] )
        >=sys-libs/zlib-1.2.11
+       udf? ( >=dev-libs/libudfread-1.0.0 )
        udev? ( virtual/udev )
        vaapi? (
                x11-libs/libva:=
@@ -228,6 +230,7 @@ src_configure() {
                -DENABLE_INTERNAL_FFMPEG="$(usex !system-ffmpeg)"
                -DENABLE_INTERNAL_FSTRCMP=OFF
                -DENABLE_INTERNAL_GTEST=OFF
+               -DENABLE_INTERNAL_UDFREAD=OFF
                -DENABLE_CAP=$(usex caps)
                -DENABLE_LCMS2=$(usex lcms)
                -DENABLE_LIRCCLIENT=$(usex lirc)
@@ -243,6 +246,7 @@ src_configure() {
                -DENABLE_SMBCLIENT=$(usex samba)
                -DENABLE_TESTING=$(usex test)
                -DENABLE_UDEV=$(usex udev)
+               -DENABLE_UDFREAD=$(usex udf)
                -DENABLE_UPNP=$(usex upnp)
                -DENABLE_VAAPI=$(usex vaapi)
                -DENABLE_VDPAU=$(usex vdpau)
index 269b8bfc2c462a97d1ad61a12e2fb504a2e05b2e..1fa46eccbfd6f8a5f43aa04ff5513497e63e3387 100644 (file)
@@ -18,6 +18,7 @@
                <flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
                <flag name="system-ffmpeg">Use system ffmpeg instead of the bundled one</flag>
                <flag name="libusb">Use <pkg>virtual/libusb</pkg> for usb device hotplug support. This flag should only be enabled if you're running a non-Linux kernel or you don't want to use <pkg>sys-fs/udev</pkg>.</flag>
+               <flag name="udf">Enable UDF support. Required for playing blurays.</flag>
                <flag name="udev">Use <pkg>sys-fs/udev</pkg> rules to handle devices' permissions and hotplug support. Unless you know what you're doing do not disable this flag on Linux kernels. This is provided as an option for completeness.</flag>
                <flag name="webserver">Enable internal webserver</flag>
                <flag name="xslt">Enable XSLT support using <pkg>dev-libs/libxslt</pkg></flag>