sys-devel/gettext: hack gettextize configure output #556024
authorMike Frysinger <vapier@gentoo.org>
Thu, 27 Aug 2015 01:49:42 +0000 (21:49 -0400)
committerMike Frysinger <vapier@gentoo.org>
Thu, 27 Aug 2015 01:50:24 +0000 (21:50 -0400)
Until upstream sorts out a fix for us, hack the output in a terrible
way so packages stop failing.  This seems to be less terrible than
just masking the new version.

sys-devel/gettext/files/gettext-0.19.5.1-version-hack.patch [new file with mode: 0644]
sys-devel/gettext/gettext-0.19.5.1-r1.ebuild [moved from sys-devel/gettext/gettext-0.19.5.1.ebuild with 94% similarity]

diff --git a/sys-devel/gettext/files/gettext-0.19.5.1-version-hack.patch b/sys-devel/gettext/files/gettext-0.19.5.1-version-hack.patch
new file mode 100644 (file)
index 0000000..1a9eaea
--- /dev/null
@@ -0,0 +1,18 @@
+the gettext tooling does not quite understand 4 version components.
+hack it so the output in the configure script sticks to 3 parts.
+this is a horrible hack that really needs an upstream fix.
+
+https://lists.gnu.org/archive/html/bug-gettext/2015-07/msg00027.html
+https://bugs.gentoo.org/556024
+
+--- a/gettext-tools/misc/gettextize.in
++++ b/gettext-tools/misc/gettextize.in
+@@ -1235,7 +1235,7 @@
+ func_modify_configure_in "(AC_OUTPUT): Remove command that created po/Makefile."
+ sed -e '/^\(dnl \|\)AC_LINK_FILES(\$nls_cv_header_libgt, \$nls_cv_header_intl)$/d' < "$srcdir/$configure_in" > "$srcdir/$configure_in.tmp"
+ func_modify_configure_in "(AC_LINK_FILES): Remove invocation."
+-sed -e 's/^AM_GNU_GETTEXT_VERSION([^()]*)/AM_GNU_GETTEXT_VERSION(['"$version"'])/' < "$srcdir/$configure_in" > "$srcdir/$configure_in.tmp"
++sed -e 's/^AM_GNU_GETTEXT_VERSION([^()]*)/AM_GNU_GETTEXT_VERSION(['"${version%.?}"'])/' < "$srcdir/$configure_in" > "$srcdir/$configure_in.tmp"
+ func_modify_configure_in "(AM_GNU_GETTEXT_VERSION): Bump to $version."
+ $do_changelog && func_ChangeLog_finish
similarity index 94%
rename from sys-devel/gettext/gettext-0.19.5.1.ebuild
rename to sys-devel/gettext/gettext-0.19.5.1-r1.ebuild
index 9e7d153732d583c0e14b099a6d8d6de863a9a529..dc2e22a616065a257a432e8c74875c4fccf7eed0 100644 (file)
@@ -39,6 +39,12 @@ MULTILIB_WRAPPED_HEADERS=(
 
 src_prepare() {
        java-pkg-opt-2_src_prepare
+
+       # This patch should not be included in version bumps (at least to 0.19.2).
+       # Perhaps 0.19.5.2 will be broken in the same way. #556024
+       [[ ${PV} != 0.19.5.1 ]] && die
+       epatch "${FILESDIR}"/${P}-version-hack.patch #556024
+
        epunt_cxx
        elibtoolize
 }