app-shells/zsh-completions: Version bump to 0.27.0
authorManuel Rüger <mrueg@gentoo.org>
Thu, 19 Oct 2017 18:42:03 +0000 (20:42 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Thu, 19 Oct 2017 18:43:21 +0000 (20:43 +0200)
Package-Manager: Portage-2.3.11, Repoman-2.3.3

app-shells/zsh-completions/Manifest
app-shells/zsh-completions/zsh-completions-0.27.0.ebuild [new file with mode: 0644]

index a6b1cbc2bf2c6215f2aa2dbf5a20bf157fc98fb0..97645196c44d4c5f49b2e823efb6d1241004ac13 100644 (file)
@@ -1 +1,2 @@
 DIST zsh-completions-0.26.0.tar.gz 218057 SHA256 783768c8308cc0ff37bce346c66386308550ede05121e352b1a284ff6bf88540 SHA512 78ba96e0c6a30271181270244488b7f2c783047714dcf1eb39918d4b258fbaf1f54b718407418ffcc62f5bf552192aca3841497c0ffb8d3e9c6ea4fb85bc1754 WHIRLPOOL 27a6273f2ae35c4413283a30c506a40c19034af89fe22cba12ec0167f5caa9e8b9e29f057fe4be609c0f54cba8f6f9c610bfe481dccc78f91c653d78b81a5849
+DIST zsh-completions-0.27.0.tar.gz 218869 SHA256 9b817b73e709aca0e7e5a41471b5b63467d1e7aa69ef755b6ce39b99e61cd47a SHA512 1c25fce14117d6eb652e2d3bfb49e68baa9f7c5832031582ec8c3066b91f07491067ff887647177048b51146beda1bcac7080abf140ea5ef846fcdd8ac388b8c WHIRLPOOL 5438c9d2cfb222179598a623f35cb7e3d61db98be0e9b204ec1c99a3475c192fa858c6a2ca7a3b78c8df617acc5471c3c032636f933f4e9800849aa1ee21b551
diff --git a/app-shells/zsh-completions/zsh-completions-0.27.0.ebuild b/app-shells/zsh-completions/zsh-completions-0.27.0.ebuild
new file mode 100644 (file)
index 0000000..74e18cd
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/zsh-users/zsh-completions.git"
+else
+       SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Additional completion definitions for Zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-completions"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+src_install() {
+       insinto /usr/share/zsh/site-functions
+       doins src/_*
+}
+
+pkg_postinst() {
+       elog
+       elog "If you happen to compile your functions, you may need to delete"
+       elog "~/.zcompdump{,.zwc} and recompile to make the new completions available"
+       elog "to your shell."
+       elog
+}