app-text/writerperfect: Fix build with USE gsf
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 10 Jun 2019 10:35:12 +0000 (12:35 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 10 Jun 2019 10:36:05 +0000 (12:36 +0200)
Closes: https://bugs.gentoo.org/687788
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/writerperfect/files/writerperfect-0.9.6-gsf-buildfix.patch [new file with mode: 0644]
app-text/writerperfect/writerperfect-0.9.6.ebuild

diff --git a/app-text/writerperfect/files/writerperfect-0.9.6-gsf-buildfix.patch b/app-text/writerperfect/files/writerperfect-0.9.6-gsf-buildfix.patch
new file mode 100644 (file)
index 0000000..0c689ec
--- /dev/null
@@ -0,0 +1,14 @@
+fix build with libgsf
+Authored by: David Tardon 2017-12-14
+
+--- a/src/lib/OutputFileHelper.cxx
++++ b/src/lib/OutputFileHelper.cxx
+@@ -57,7 +57,7 @@
+ OutputFileHelperImpl::~OutputFileHelperImpl()
+ {
+ #ifdef USE_GSF_OUTPUT
+-      if (mpOutfile && !gsf_output_close((GsfOutput *) mpOutfile.get()))
++      if (mpOutfile && !gsf_output_close((GsfOutput *) mpOutfile))
+               fprintf(stderr, "ERROR : Couldn't close outfile\n");
+       if (mpOutfile)
index b6dba7c029d1651cc1834d2294cb697593a77145..4079835b3f7f817d8fa7fa337cc19691e051f96c 100644 (file)
@@ -12,6 +12,11 @@ SLOT="0"
 KEYWORDS="amd64 ~x86 ~x86-linux ~x86-solaris"
 IUSE="abiword +cdr debug ebook epub freehand gsf keynote +mspub +mwaw pagemaker qxp +visio +wpd +wpg +wps zmf"
 
+# configure fails if no import library is selected...
+REQUIRED_USE="
+       || ( abiword cdr ebook freehand keynote mspub mwaw pagemaker qxp visio wpd wpg wps zmf )
+"
+
 # FIXME: librvngabw
 BDEPEND="
        virtual/pkgconfig
@@ -39,10 +44,7 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
-REQUIRED_USE="
-       || ( abiword cdr ebook freehand keynote mspub mwaw pagemaker qxp visio wpd wpg wps zmf )
-"
-# configure fails if no import library is selected...
+PATCHES=( "${FILESDIR}/${P}-gsf-buildfix.patch" )
 
 src_configure() {
        local myeconfargs=(