sci-geosciences/osm2pgsql: Sync live w/ release and back
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 13 Feb 2020 20:49:43 +0000 (21:49 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 13 Feb 2020 21:27:50 +0000 (22:27 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-geosciences/osm2pgsql/osm2pgsql-0.96.0.ebuild
sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild

index a6cb7e42a469b048d922ff9708795048e4460968..e5e751831c5dc941e2c2c84e5f2c700ca174dde6 100644 (file)
@@ -5,9 +5,9 @@ EAPI=7
 
 inherit cmake flag-o-matic
 
-DESCRIPTION="Converts OSM data to SQL and insert into PostgreSQL db"
+DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
 HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql
-                 https://github.com/openstreetmap/osm2pgsql"
+       https://github.com/openstreetmap/osm2pgsql"
 SRC_URI="https://github.com/openstreetmap/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2"
index 44e16db480410aee6b1e21e2bb71e531a0ef3eb5..78b4534c993ed34064fa74533ef320752bed8f41 100644 (file)
@@ -1,14 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit cmake-utils git-r3
+inherit cmake flag-o-matic git-r3
 
 EGIT_REPO_URI="https://github.com/openstreetmap/${PN}.git"
 
 DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
-HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql"
+HOMEPAGE="https://wiki.openstreetmap.org/wiki/Osm2pgsql
+       https://github.com/openstreetmap/osm2pgsql"
 SRC_URI=""
 
 LICENSE="GPL-2"
@@ -20,7 +21,7 @@ COMMON_DEPEND="
        app-arch/bzip2
        dev-db/postgresql:=
        dev-libs/expat
-       sci-libs/proj
+       sci-libs/proj:=
        sys-libs/zlib
        lua? ( dev-lang/lua:= )
 "
@@ -35,9 +36,10 @@ RDEPEND="${COMMON_DEPEND}
 RESTRICT="test"
 
 src_configure() {
+       append-cppflags -DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1
        local mycmakeargs=(
                -DWITH_LUA=$(usex lua)
                -DBUILD_TESTS=OFF
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }