dev-ruby/launchy: add ruby23 revision
authorHans de Graaff <graaff@gentoo.org>
Sun, 4 Sep 2016 06:42:48 +0000 (08:42 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 4 Sep 2016 06:47:04 +0000 (08:47 +0200)
Package-Manager: portage-2.2.28

dev-ruby/launchy/launchy-2.4.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/launchy/launchy-2.4.3-r1.ebuild b/dev-ruby/launchy/launchy-2.4.3-r1.ebuild
new file mode 100644 (file)
index 0000000..a7e9b83
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Helper class for launching cross-platform applications"
+HOMEPAGE="https://github.com/copiousfreetime/launchy"
+
+LICENSE="ISC"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# File collision conflict with x11-misc/launchy, bug 545170
+ruby_add_rdepend ">=dev-ruby/addressable-2.3 !!x11-misc/launchy"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.0:5 )"
+
+# This test is expected to fail on linux, drop it
+RUBY_PATCHES=( "${FILESDIR}"/${PN}-2.4.2-drop-failing-test.patch )
+
+all_ruby_prepare() {
+       sed -i -e "/[Ss]implecov/d" spec/spec_helper.rb || die
+
+       # Avoid tests depending on the current user's desktop environment.
+       sed -e '/returns NotFound if it cannot determine/askip "gentoo"' \
+               -i spec/detect/nix_desktop_environment_spec.rb || die
+       sed -e '/asssumes we open a local file if we have an exception/askip "gentoo"' \
+               -i spec/launchy_spec.rb || die
+}