dev-vcs/mercurial: Use filter-flags instead of strip-flags
authorCédric Krier <cedk@gentoo.org>
Sun, 15 Mar 2020 10:24:28 +0000 (11:24 +0100)
committerCédric Krier <cedk@gentoo.org>
Mon, 16 Mar 2020 11:03:14 +0000 (12:03 +0100)
Closes: https://bugs.gentoo.org/712594
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Cédric Krier <cedk@gentoo.org>
dev-vcs/mercurial/mercurial-4.6.2.ebuild
dev-vcs/mercurial/mercurial-4.9-r2.ebuild
dev-vcs/mercurial/mercurial-4.9.1.ebuild
dev-vcs/mercurial/mercurial-5.0.2.ebuild
dev-vcs/mercurial/mercurial-5.1.2.ebuild
dev-vcs/mercurial/mercurial-5.2.2-r1.ebuild
dev-vcs/mercurial/mercurial-9999.ebuild

index 135710a8f27a80442ee70e10b938f79e77b0d7ec..1c5db61c0499c0423a39614e09f8caf6ca506010 100644 (file)
@@ -41,7 +41,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+       filter-flags -ftracer -ftree-vectorize
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 25fa556dc7ae89dfbdcdc0ad77034081b37ba0b3..a878d8730ad6fc16eaf48d51e524d6cc3f9bea4c 100644 (file)
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+       filter-flags -ftracer -ftree-vectorize
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index c50921ab4f38e4578d07897cfe065057484297df..435caf12f6ea6819e0fb9c7031fbcb6aebb9cfac 100644 (file)
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+       filter-flags -ftracer -ftree-vectorize
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 8e116e6682033b1ccafc3a0fc94a0d14e753a937..117dc6be168c4f0a0dbda68349132cc5d5d2173e 100644 (file)
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+       filter-flags -ftracer -ftree-vectorize
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 24db3c875e13c9810b5d68aed79e0d8c7380b3ff..88464e063967d31d2bfa592d8dd5f633ec5eb498 100644 (file)
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+       filter-flags -ftracer -ftree-vectorize
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 5ee7bb5b45f817f5900a47c49cbe4053122319ce..6cf8acb5c9cc268c0d46ef1d4bb8717652ff83a2 100644 (file)
@@ -55,7 +55,7 @@ python_prepare_all() {
 }
 
 python_compile() {
-       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+       filter-flags -ftracer -ftree-vectorize
        python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile build_ext --no-zstd
 }
index 6a75f6d2818d5b72f9043c3d6ec230e47ac1cf27..a62bf9062fdc1109a9059266a235e90d80c82ec1 100644 (file)
@@ -57,7 +57,7 @@ python_prepare_all() {
 }
 
 python_compile() {
-       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+       filter-flags -ftracer -ftree-vectorize
        python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile build_ext --no-zstd
 }