app-text/pdftk: Make this build with gcc-5 for now
authorAndreas K. Huettel <dilfridge@gentoo.org>
Mon, 27 Nov 2017 17:43:52 +0000 (18:43 +0100)
committerAndreas K. Huettel <dilfridge@gentoo.org>
Mon, 27 Nov 2017 17:44:42 +0000 (18:44 +0100)
Hardwire pdftk to use gcc-5.4.0, and depend on it

Bug: https://bugs.gentoo.org/562568
Package-Manager: Portage-2.3.16, Repoman-2.3.6

app-text/pdftk/pdftk-2.02.ebuild

index 0aa09e4f2ac27f03e13118f6bc1794b8a3c87865..d026f23fdf6954bb9b85783468a77148ca6821a8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -13,8 +13,10 @@ LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux"
 
-DEPEND="sys-devel/gcc[gcj]"
-RDEPEND="${DEPEND}"
+RDEPEND="sys-devel/gcc:5.4.0[gcj]"
+DEPEND="${RDEPEND}
+       sys-devel/gcc-config
+"
 
 S="${WORKDIR}/${P}-dist/${PN}"
 
@@ -27,6 +29,9 @@ src_compile() {
        unset CLASSPATH
        unset JAVA_HOME
 
+       # We need gcc-5 because of Java
+       export PATH="$(gcc-config -B 5.4.0):${PATH}"
+
        # Parallel make fails; confirmed, still not fixed in version 2.02.
        emake -j1 -f "${S}"/Makefile.Debian || die "Compilation failed."
 }