app-vim/autoalign: Bump version to 14
authorAaron U'Ren <aauren@gmail.com>
Tue, 8 Sep 2015 18:43:28 +0000 (11:43 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 8 Sep 2015 22:29:35 +0000 (15:29 -0700)
Package-Manager: portage-2.2.20

app-vim/autoalign/Manifest
app-vim/autoalign/autoalign-14.ebuild [new file with mode: 0644]

index a6a79db33dd01562a6390b8a195542bd29a3a99e..91a4065dbd4fc4e34701bfefc51788d08a75a768 100644 (file)
@@ -1 +1,2 @@
 DIST autoalign-13.tar.bz2 10091 SHA256 30151a1d22e94d8be919f0ac097ab348830b943d2672db49afccca707f86b058 SHA512 2ea94b97a9a0a5a2f5488e201be3297d29246a348b07d15b3bdd37a8c294cb3c6941b9d70ac0fda143b6fdcda30df6b228309089303f5dafe2bc4cacd7492fff WHIRLPOOL f7dcd193c74f43db8a9eabbcd200dcf4d9004a3b33d52293e58d17aa707bdc18b8a5a25bdf0a3e149c55806591eefc23b4bc6af1bc0426e97d910ef4ec30d6ea
+DIST autoalign-14.tar.xz 13400 SHA256 7de8566fad877554b83e5c268aa7796d20a32c7b211fe01eb11ac35ee4bf3536 SHA512 40107b8e12c4190c4f31c740d9b7615eb0836f4d159e6071526de768e6f7726849cb0cd93af8674aff7d6cfecc1b7f27d5b894628f426c51941bb914b92944f2 WHIRLPOOL d7db1aacc8068bcc6874721aa1547797551a0b5300fc9ec31cb091cc858a8105aa4feb14c9edb4ad4a592b3b98600ebdf88226622d189cd2849e7fd2a18efb8c
diff --git a/app-vim/autoalign/autoalign-14.ebuild b/app-vim/autoalign/autoalign-14.ebuild
new file mode 100644 (file)
index 0000000..3f0cf76
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: automatically align bib, c, c++, tex and vim code"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=884"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+if [[ ${PV} != 9999* ]] ; then
+       SRC_URI="mirror://gentoo/${P}.tar.xz
+               http://dev.gentoo.org/~chutzpah/vim/${P}.tar.xz"
+fi
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-vim/align-30
+       >=app-vim/cecutil-4"
+
+VIM_PLUGIN_HELPFILES="autoalign"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+       # Don't use the cecutil.vim included in the tarball, use the one
+       # provided by app-vim/cecutil instead.
+       rm plugin/cecutil.vim
+}