dev-perl/MogileFS-Server: bump
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 8 Nov 2019 14:22:58 +0000 (06:22 -0800)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 8 Nov 2019 14:23:06 +0000 (06:23 -0800)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-perl/MogileFS-Server/Manifest
dev-perl/MogileFS-Server/MogileFS-Server-2.730.0.ebuild [new file with mode: 0644]

index 2df344166844e150906dbbc4bb25f69d04fcc49a..4f4b83aa5f41a60a9935692ed327d2439fe16697 100644 (file)
@@ -1 +1,2 @@
 DIST MogileFS-Server-2.72.tar.gz 200057 BLAKE2B 835a7799389e536b42ed000b8ce07225609501ee6a4c002253a0018d0b17c815e8825a56f78ee0c0604d57cafea45ac044fda4e6e6bc33e0b60b8ed5b51a7e10 SHA512 4076ba33123c984f9d7c56db7d308b4d857e852caa8d811d86ed551b9ab74a6dfc93b034d034ec2802376035799860c613aef2bdd3898c1225e37727fda34ade
+DIST MogileFS-Server-2.73.tar.gz 202285 BLAKE2B bd7032a507df8eba7e8c48205a8d76e66a85e28a2223bce47a1753c38d700a5e8b3ab72e5bffd592d1aec4918374e57d3bf882b911f3d5fb6d1f403a4d32275f SHA512 9d5f67334d1877e9a6e63abb728a9d00b93f35579057102b9601a9c65bd3ff8438090e560ddefaec04ce24d4d2c9a7554d7ea2595b5e4ba6f4f2c4554ccac268
diff --git a/dev-perl/MogileFS-Server/MogileFS-Server-2.730.0.ebuild b/dev-perl/MogileFS-Server/MogileFS-Server-2.730.0.ebuild
new file mode 100644 (file)
index 0000000..1ab8f1f
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DORMANDO
+DIST_VERSION=${PV%0.0}
+inherit user perl-module
+
+DESCRIPTION="Server for the MogileFS distributed file system"
+HOMEPAGE="http://www.danga.com/mogilefs/ ${HOMEPAGE}"
+
+IUSE="mysql sqlite test postgres"
+REQUIRED_USE="test? ( sqlite ) || ( mysql sqlite postgres )"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# Upstream site recommends this,
+# but it breaks Perlbal
+# dev-perl/Perlbal-XS-HTTPHeaders
+RDEPEND="dev-perl/Net-Netmask
+               >=dev-perl/Danga-Socket-1.610.0
+               >=dev-perl/Sys-Syscall-0.220.0
+               >=dev-perl/Perlbal-1.790
+               >=dev-perl/IO-AIO-4
+               dev-perl/libwww-perl
+               >=dev-perl/MogileFS-Client-1.170.0
+               >=dev-perl/MogileFS-Utils-2.280.0
+               dev-perl/Cache-Memcached
+               dev-perl/DBI
+               mysql? ( dev-perl/DBD-mysql )
+               postgres? ( dev-perl/DBD-Pg )
+               sqlite? ( dev-perl/DBD-SQLite )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-2.720.0-gentoo-init-conf.patch"
+)
+DIST_TEST="never"
+
+MOGILE_USER="mogile"
+
+pkg_setup() {
+       # Warning! It is important that the uid is constant over Gentoo machines
+       # As mogilefs may be used with non-local block devices that move!
+       enewuser ${MOGILE_USER} 460 -1 -1
+}
+
+src_install() {
+       perl-module_src_install || die "perl-module_src_install failed"
+       cd "${S}"
+
+       newconfd "${S}"/gentoo/conf.d/mogilefsd mogilefsd
+       newinitd "${S}"/gentoo/init.d/mogilefsd mogilefsd
+
+       newconfd "${S}"/gentoo/conf.d/mogstored mogstored
+       newinitd "${S}"/gentoo/init.d/mogstored mogstored
+
+       newinitd "${S}"/gentoo/init.d/mogautomount mogautomount
+
+       diropts -m 700 -o ${MOGILE_USER}
+       keepdir /var/mogdata
+
+       diropts -m 755 -o root
+       dodir /etc/mogilefs
+
+       insinto /etc/mogilefs
+       insopts -m 600 -o root -g ${MOGILE_USER}
+       newins "${S}"/gentoo/conf/mogilefsd.conf mogilefsd.conf
+       newins "${S}"/gentoo/conf/mogstored.conf mogstored.conf
+}
+
+pkg_postinst() {
+       chmod 640 "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
+       chown root:${MOGILE_USER} "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
+}
+
+#src_test() {
+#      emake test MOGTEST_DBUSER=mogile MOGTEST_DBNAME=tmp_mogiletest MOGTEST_DBTYPE=SQLite
+#}